Project

General

Profile

Bug #2027

open-uri doesn't suport redirections to secure servers

Added by m.carrasco.m (Manuel Carrasco) almost 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
ruby -v:
ruby 1.8.7 (2008-05-31 patchlevel 0) [x86_64-linux]
[ruby-core:25247]

Description

=begin
When the server reponse is a redirection to a secure server, open-uri fails raising a runtime exception with this message:

(RuntimeError) redirection forbidden: http://hudson.gotdns.com/latest/hudson.war -> https://hudson.dev.java.net/files/documents/2402/142380/hudson.war
/mirai/SOFT/ruby/1.8.7/lib/ruby/1.8/open-uri.rb:174:in open_loop'
/mirai/SOFT/ruby/1.8.7/lib/ruby/1.8/open-uri.rb:132:in
open_uri'

I attach a patch that fixes this issue.

Thanks
=end


Files

open_uri_redirects_to_https.patch (589 Bytes) open_uri_redirects_to_https.patch m.carrasco.m (Manuel Carrasco), 09/02/2009 12:30 AM

Related issues

Is duplicate of Ruby master - Feature #859: open-uri doesn't allow redirection to httpsClosed01/31/2012Actions

History

#1

Updated by m.carrasco.m (Manuel Carrasco) almost 10 years ago

=begin
Please, mark this this ticket as duplicated because there is another one reporting the same issue: #859
=end

#2

Updated by shyouhei (Shyouhei Urabe) almost 10 years ago

  • Status changed from Open to Closed

=begin

=end

Also available in: Atom PDF