Project

General

Profile

Bug #2316

[BUG] cfp consistency error

Added by Cezary (Cezary Baginski) almost 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
ruby -v:
ruby 1.9.2dev (2009-10-30 trunk 25576) [i686-linux]
[ruby-core:26447]

Description

=begin
Happens every time running cucumber on small project.

I feel too dumb to debug this myself - sorry.

Let me know if additional information is required from my side.

  • NOTE: I haven't run 'make test-all' yet. =end

Files

q2.txt (9.22 KB) q2.txt Cezary (Cezary Baginski), 10/31/2009 06:27 PM

Related issues

Is duplicate of Ruby master - Bug #2311: [BUG] cfp consistency error - sendClosed10/30/2009Actions

History

#1

Updated by Cezary (Cezary Baginski) almost 10 years ago

=begin
'make test-all' gives the following failure:

1) Failure:
test_free=(DL::TestCPtr) [/home/media/git-pool/ruby/test/dl/test_cptr.rb:12]:
[ruby-dev:39269]
pid 10650 killed by SIGABRT (signal 6)
| -: [BUG] Segmentation fault
| ruby 1.9.2dev (2009-10-30 trunk 25576) [i686-linux]
|
| -- control frame ----------
| c:0001 p:0000 s:0002 b:0002 l:001ab4 d:001ab4 TOP

| ---------------------------
|
| -- C level backtrace information -------------------------------------------
| /home/media/git-pool/ruby/ruby(rb_vm_bugreport+0x6b) [0x8144e38]
| /home/media/git-pool/ruby/ruby [0x817457b]
| /home/media/git-pool/ruby/ruby(rb_bug+0x34) [0x81745e9]
| /home/media/git-pool/ruby/ruby [0x80e508e]
| [0x4001d410]
| /lib/libc.so.6(cfree+0x6d) [0x4035350d]
| /home/media/git-pool/ruby/.ext/i686-linux/dl.so [0x402c6fed]
| /home/media/git-pool/ruby/ruby [0x8066425]
| /home/media/git-pool/ruby/ruby [0x8064dfe]
| /home/media/git-pool/ruby/ruby [0x806689a]
| /home/media/git-pool/ruby/ruby(rb_gc_call_finalizer_at_exit+0x19) [0x8066669]
| /home/media/git-pool/ruby/ruby [0x805e083]
| /home/media/git-pool/ruby/ruby(ruby_cleanup+0x141) [0x805e1d8]
| /home/media/git-pool/ruby/ruby(ruby_run_node+0x40) 0x805e448
=end

#2

Updated by marcandre (Marc-Andre Lafortune) almost 10 years ago

  • Assignee set to matz (Yukihiro Matsumoto)
  • Priority changed from Normal to 5

=begin
Looks like the same issue as #2311.

Solutions until it is resolved:

  • do not run any tests that generate a "wrong number of arguments" error,
  • or use ruby earlier than r25521, or revert that commit locally. =end
#3

Updated by matz (Yukihiro Matsumoto) almost 10 years ago

=begin
Hi,

In message "Re: [ruby-core:26451] [Bug #2316] [BUG] cfp consistency error"
on Sun, 1 Nov 2009 02:49:11 +0900, Marc-Andre Lafortune redmine@ruby-lang.org writes:

|Looks like the same issue as #2311.

No. According to [ruby-dev:39269], it's caused by dl test, and I
believe this is a bug in test. At least, this one is not related to
r25521 at all. It's far older than that.

dl touches internals directly so that you can crash the interpreter
pretty easily. In this case, the test frees the memory region by
using free() taken from libc, but the region itself is allocated by
ruby_xmalloc(). This mismatch might be the reason of the crash.

But, in that case, I see no reason to have CPtr#free= method at all.

|Solutions until it is resolved:
|- do not run any tests that generate a "wrong number of arguments" error,
|- or use ruby earlier than r25521, or revert that commit locally.

This solution is for #2311 (which I cannot reproduce right now), but
not for this one.

                        matz.

=end

#4

Updated by marcandre (Marc-Andre Lafortune) almost 10 years ago

=begin
Hi Matz,

The update Cezary posted about a test failing in test-all is because of [ruby-dev:39269], but it is not related to his issue.

You need to look at the attachment filed on redmine. I believe the issue is posting is the same as #2311.

When you say you can not reproduce, you mean that the two examples I gave in #2311 do not give you any trouble?
=end

#5

Updated by matz (Yukihiro Matsumoto) almost 10 years ago

=begin
Hi,

In message "Re: [ruby-core:26455] [Bug #2316] [BUG] cfp consistency error"
on Sun, 1 Nov 2009 04:29:30 +0900, Marc-Andre Lafortune redmine@ruby-lang.org writes:

|When you say you can not reproduce, you mean that the two examples I gave in #2311 do not give you any trouble?

No, I misunderstood the case. I could reproduce.

=end

#6

Updated by matz (Yukihiro Matsumoto) almost 10 years ago

  • Status changed from Open to Closed

=begin
This issue was solved with changeset r25681.
Marc-Andre, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF