Project

General

Profile

Bug #2461

ARGF.rewind does not reset ARGF.lineno to zero

Added by nahi (Hiroshi Nakamura) over 8 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.8.8dev (2009-12-07 revision 25983) [i686-linux]
[ruby-core:27097]

Description

=begin
0% ruby19 -ve 'ARGF.gets; ARGF.rewind; p [ARGF.lineno, $.]; ARGF.gets; p [ARGF.lineno, $.]' ~/.zshhist
ruby 1.9.2dev (2009-12-01 trunk 25970) [i686-linux]
[0, 1]
[1, 1]
0% ruby -ve 'ARGF.gets; ARGF.rewind; p [ARGF.lineno, $.]; ARGF.gets; p [ARGF.lineno, $.]' ~/.zshhist
ruby 1.8.8dev (2009-12-07 revision 25983) [i686-linux]
[1, 1]
[1, 1]
0%

1.9 is correct, right?
=end

History

#1 Updated by nahi (Hiroshi Nakamura) over 8 years ago

  • Status changed from Open to Rejected

=begin
Sorry, it's duplicate of #1693
=end

Also available in: Atom PDF