Project

General

Profile

Backport #2486

cross-compile 1.9.1-p376 fails

Added by luislavena (Luis Lavena) over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:27196]

Description

=begin
When cross-compiling (target: i386-mingw32), Ruby 1.9.1-p376 fails with the following error:

i586-mingw32msvc-gcc -O2 -g -Wall -Wno-parentheses -I. -I.ext/include/i386-mingw32 -I/home/luis/.rake-compiler/sources/ruby-1.9.1-p376/include -I/home/luis/.rake-compiler/sources/ruby-1.9.1-p376 -DRUBY_EXPORT -o win32.o -c /home/luis/.rake-compiler/sources/ruby-1.9.1-p376/win32/win32.c
/home/luis/.rake-compiler/sources/ruby-1.9.1-p376/win32/win32.c: In function "winnt_stat":
/home/luis/.rake-compiler/sources/ruby-1.9.1-p376/win32/win32.c:3549: warning: pointer targets in passing argument 1 of "_mbspbrk" differ in signedness
/home/luis/.rake-compiler/sources/ruby-1.9.1-p376/win32/win32.c:3549: warning: pointer targets in passing argument 2 of "_mbspbrk" differ in signedness
/home/luis/.rake-compiler/sources/ruby-1.9.1-p376/win32/win32.c: In function "rb_w32_write":
/home/luis/.rake-compiler/sources/ruby-1.9.1-p376/win32/win32.c:4607: error: lvalue required as left operand of assignment
make: *** [win32.o] Error 1

Find attached config.log, config.status and rbconfig.rb (to help debug if needed, but I think in this case the issue is pure C)
=end


Files

config.status (29 KB) config.status luislavena (Luis Lavena), 12/16/2009 05:11 PM
config.log.zip (24.8 KB) config.log.zip luislavena (Luis Lavena), 12/16/2009 05:11 PM
rbconfig.rb (7.48 KB) rbconfig.rb luislavena (Luis Lavena), 12/16/2009 05:11 PM

History

#1

Updated by usa (Usaku NAKAMURA) over 9 years ago

  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)

=begin
Yugui, please backport r21986 to ruby_1_9_1.
=end

#2

Updated by luislavena (Luis Lavena) about 9 years ago

=begin
Hello,

as revision 28641 of ruby_1_9_1 branch this issue seems to be solved.

Thank you.
=end

#3

Updated by naruse (Yui NARUSE) almost 9 years ago

  • Status changed from Assigned to Closed

=begin

=end

Also available in: Atom PDF