Project

General

Profile

Backport #2548

Marshal dump/load fails when given an array containing certain (rather silly) symbols

Added by coatl (caleb clausen) over 9 years ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
[ruby-core:27375]

Description

=begin
Either Marshal.dump or Marshal.load is failing to do the right thing with certain symbols which name backreference variables of unusual size. Here's the simplest example I could find:

$ ruby19 -e 'p Marshal.load Marshal.dump [:$98349576875974523789734582394578,nil]'
-e:1:in load': dump format error(0x0) (ArgumentError)
from -e:1:in
'

This case works without a problem in ruby 1.8. The problem goes away if the second element of the array is left off, or if the symbol is used by itself without an array enclosing it. Marshal.load is raising the error, but I'm not sure if the problem is there or if Marshal.dump is emitting something incorrect.

Tested on ruby 1.9.1, but I'm guessing 1.9.2 has the same issue.
=end


Related issues

Has duplicate Backport191 - Backport #3729: Fwd: 1.9.1 has marshal bugs in everything but p129ClosedActions

History

#1

Updated by coatl (caleb clausen) over 9 years ago

=begin
I've since discovered that you don't have to use a backreference of unusual size; any backreference will do. A variety of other more normal symbols are also affected. Here's a list of some other failing cases:

$ ruby19 -e 'p Marshal.load Marshal.dump [:$1,nil]
-e:1:in load': dump format error(0x0) (ArgumentError)
from -e:1:in
'

$ ruby19 -e 'p Marshal.load Marshal.dump [:$0,nil]
-e:1:in load': dump format error(0x0) (ArgumentError)
from -e:1:in
'

$ ruby19 -e 'p Marshal.load Marshal.dump [:$&,nil]
-e:1:in load': dump format error(0x0) (ArgumentError)
from -e:1:in
'

$ ruby19 -e 'p Marshal.load Marshal.dump [:$,nil]
-e:1:in
load': dump format error(0x0) (ArgumentError)
from -e:1:in `'

$ ruby19 -e 'p Marshal.load Marshal.dump [:$$,nil]
-e:1:in load': dump format error(0x0) (ArgumentError)
from -e:1:in
'

$ ruby19 -e 'p Marshal.load Marshal.dump [:$-a,nil]
-e:1:in load': dump format error(0x0) (ArgumentError)
from -e:1:in
'

So, the inputs to make this happen aren't so silly after all.
=end

#2

Updated by nobu (Nobuyoshi Nakada) almost 9 years ago

  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)

=begin

=end

#3

Updated by jeremyevans0 (Jeremy Evans) 1 day ago

  • Status changed from Assigned to Closed
  • Description updated (diff)

Also available in: Atom PDF