Project

General

Profile

Actions

Bug #2555

closed

"case n when *VALID" Broken in Ruby 1.8.8; affects Ruby on Rails

Added by rubys (Sam Ruby) over 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.8.8dev (2010-01-01 revision 26226) [x86_64-linux]
[ruby-core:27395]

Description

=begin
This affects uses of the "builder" gem.

Related commits:

http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=rev&revision=24695
http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=rev&revision=25658

Results when run against selected versions of 1.8.8:

ruby 1.8.8dev (2009-08-26 revision 24669) [x86_64-linux]
a
valid
valid

ruby 1.8.8dev (2009-08-26 revision 24695) [x86_64-linux]
*
INVALID
INVALID

ruby 1.8.8dev (2009-11-05 revision 25657) [x86_64-linux]
*
INVALID
INVALID

ruby 1.8.8dev (2009-11-05 revision 25658) [x86_64-linux]
*
valid
INVALID
=end


Files

valid.rb (562 Bytes) valid.rb rubys (Sam Ruby), 01/05/2010 03:01 AM

Related issues 2 (0 open2 closed)

Related to Ruby 1.8 - Bug #2468: Array expansion inside case/when gives unexpected resultsClosed12/10/2009Actions
Is duplicate of Ruby 1.8 - Bug #2551: case/when matches literal *[1,2,3] but not variable *aryClosed01/03/2010Actions
Actions #1

Updated by rubys (Sam Ruby) over 12 years ago

=begin
I should have mentioned that the attachment is the test case.
=end

Actions #2

Updated by bitsweat (Jeremy Daer) over 12 years ago

=begin
Duplicates #2551, #2468.
=end

Actions #3

Updated by knu (Akinori MUSHA) over 12 years ago

  • Status changed from Open to Closed

=begin
This issue was solved with changeset r26589.
Romulo, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Actions #4

Updated by rubys (Sam Ruby) over 12 years ago

=begin
The test case provided still fails.

As near as I can tell, changeset r26589 only contains test cases, but no changes to Ruby itself.

Please reopen this bug.
=end

Actions #5

Updated by knu (Akinori MUSHA) over 12 years ago

=begin
I never meant to close this.

I wish "ref [Bug #...]" would have been parsed just like "cf: [Bug #...]".

=end

Actions #6

Updated by marcandre (Marc-Andre Lafortune) over 12 years ago

  • Category set to core
  • Status changed from Closed to Open

=begin

=end

Actions #8

Updated by naruse (Yui NARUSE) about 12 years ago

  • Status changed from Open to Closed

=begin

I wish "ref [Bug #...]" would have been parsed just like "cf: [Bug #...]".
#... may change when the ticket moves from bug to backport or something.
So writing ref #... is correct.
=end

Actions

Also available in: Atom PDF