Project

General

Profile

Bug #2738

Segmentation fault - rake test

Added by sergeykish (Sergey Kish) over 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
ruby -v:
ruby 1.9.1p378 (2010-01-10 revision 26273) [i686-linux]
[ruby-core:28149]

Description

=begin
Hello

I get permanent Segmentation fault on empty rails application with one test case.

~/project/rails$ rails test
~/project/rails$ cd test/
~/project/rails/test$ cp ../quacking-like-ar/test/functional/house_searches_test.rb test/functional/
~/project/rails/test$ rake db:migrate
(in /home/arch/project/rails/test)
~/project/rails/test$ rake test
(in /home/arch/project/rails/test)
/usr/bin/ruby -I"lib:test" "/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb"

/usr/bin/ruby -I"lib:test" "/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb" "test/functional/house_searches_test.rb"
/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5: [BUG] Segmentation fault
ruby 1.9.1p378 (2010-01-10 revision 26273) [i686-linux]

-- control frame ----------
c:0007 p:---- s:0018 b:0018 l:000017 d:000017 CFUNC :load
c:0006 p:0023 s:0014 b:0014 l:000adc d:000013 BLOCK /usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5
c:0005 p:---- s:0011 b:0011 l:000010 d:000010 FINISH
c:0004 p:---- s:0009 b:0009 l:000008 d:000008 CFUNC :each
c:0003 p:0015 s:0006 b:0006 l:000adc d:0013ec EVAL /usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:000adc d:000adc TOP


-- Ruby level backtrace information-----------------------------------------
/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5:in load'
/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5:in
block in '
/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5:in each'
/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5:in
'

-- C level backtrace information -------------------------------------------
0xb777d1b0 /usr/lib/libruby.so.1.9(rb_vm_bugreport+0x60) [0xb777d1b0]
0xb7699c61 /usr/lib/libruby.so.1.9(+0x45c61) [0xb7699c61]
0xb7699cfa /usr/lib/libruby.so.1.9(rb_bug+0x3a) [0xb7699cfa]
0xb77242bc /usr/lib/libruby.so.1.9(+0xd02bc) [0xb77242bc]
0xb77dc40c [0xb77dc40c]
0xb76e7034 /usr/lib/libruby.so.1.9(ruby_yyparse+0x6c74) [0xb76e7034]
0xb76ef0c6 /usr/lib/libruby.so.1.9(+0x9b0c6) [0xb76ef0c6]
0xb778013b /usr/lib/libruby.so.1.9(ruby_suppress_tracing+0x10b) [0xb778013b]
0xb76db40d /usr/lib/libruby.so.1.9(+0x8740d) [0xb76db40d]
0xb76db488 /usr/lib/libruby.so.1.9(rb_parser_compile_file+0x68) [0xb76db488]
0xb7722dd0 /usr/lib/libruby.so.1.9(+0xcedd0) [0xb7722dd0]
0xb769b289 /usr/lib/libruby.so.1.9(rb_ensure+0x99) [0xb769b289]
0xb7720cf5 /usr/lib/libruby.so.1.9(+0xcccf5) [0xb7720cf5]
0xb7720d3c /usr/lib/libruby.so.1.9(rb_load_file+0x3c) [0xb7720d3c]
0xb769de52 /usr/lib/libruby.so.1.9(rb_load+0x132) [0xb769de52]
0xb769dff7 /usr/lib/libruby.so.1.9(+0x49ff7) [0xb769dff7]
0xb776ac08 /usr/lib/libruby.so.1.9(+0x116c08) [0xb776ac08]
0xb776af44 /usr/lib/libruby.so.1.9(+0x116f44) [0xb776af44]
0xb777743e /usr/lib/libruby.so.1.9(+0x12343e) [0xb777743e]
0xb7770a9e /usr/lib/libruby.so.1.9(+0x11ca9e) [0xb7770a9e]
0xb7773f13 /usr/lib/libruby.so.1.9(+0x11ff13) [0xb7773f13]
0xb7778c4b /usr/lib/libruby.so.1.9(rb_yield+0x1cb) [0xb7778c4b]
0xb7674db2 /usr/lib/libruby.so.1.9(rb_ary_each+0x52) [0xb7674db2]
0xb776abed /usr/lib/libruby.so.1.9(+0x116bed) [0xb776abed]
0xb776af44 /usr/lib/libruby.so.1.9(+0x116f44) [0xb776af44]
0xb777743e /usr/lib/libruby.so.1.9(+0x12343e) [0xb777743e]
0xb7770a9e /usr/lib/libruby.so.1.9(+0x11ca9e) [0xb7770a9e]
0xb7773f13 /usr/lib/libruby.so.1.9(+0x11ff13) [0xb7773f13]
0xb777418b /usr/lib/libruby.so.1.9(rb_iseq_eval_main+0xab) [0xb777418b]
0xb769be77 /usr/lib/libruby.so.1.9(ruby_exec_node+0xb7) [0xb769be77]
0xb769d496 /usr/lib/libruby.so.1.9(ruby_run_node+0x56) [0xb769d496]
0x80486a8 /usr/bin/ruby(main+0x68) [0x80486a8]
0xb7510b86 /lib/libc.so.6(__libc_start_main+0xe6) [0xb7510b86]
0x80485a1 /usr/bin/ruby() [0x80485a1]

[NOTE]
You may encounter a bug of Ruby interpreter. Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

/usr/bin/ruby -I"lib:test" "/usr/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader.rb"

Errors running test:functionals!

It as Arch Linux

$ uname -a
Linux localhost 2.6.31-ARCH #1 SMP PREEMPT Tue Nov 10 19:48:17 CET 2009 i686 Intel(R) Atom(TM) CPU Z520 @ 1.33GHz GenuineIntel GNU/Linux

With a lot of gems

$ gem list

*** LOCAL GEMS ***

actionmailer (2.3.5)
actionpack (2.3.5)
activemerchant (1.5.0, 1.4.2)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
authlogic (2.1.3)
autotest-rails (4.1.0)
builder (2.1.2)
capistrano (2.5.14)
cgi_multipart_eof_fix (2.5.0)
configuration (1.1.0)
cucumber (0.6.2)
cucumber-rails (0.2.4)
daemons (1.0.10)
database_cleaner (0.4.3)
diff-lcs (1.1.2)
fastthread (1.0.7)
formtastic (0.9.7)
gem_plugin (0.2.3)
gemcutter (0.3.0)
haml (2.2.19, 2.2.17)
heroku (1.7.1, 1.6.5)
highline (1.5.2, 1.5.1)
hirb (0.2.9)
hoe (2.5.0)
hpricot (0.8.2)
httpclient (2.1.5.2)
json (1.2.0)
json_pure (1.2.0)
launchy (0.3.5)
mime-types (1.16)
mkrf (0.2.3)
mocha (0.9.8)
mysql (2.8.1)
net-scp (1.0.2)
net-sftp (2.0.4)
net-ssh (2.0.20, 2.0.19)
net-ssh-gateway (1.0.1)
nifty-generators (0.3.0)
nokogiri (1.4.1)
polyglot (0.2.9)
rack (1.1.0, 1.0.1)
rack-test (0.5.3)
rails (2.3.5)
rake (0.8.7)
rest-client (1.3.1, 1.3.0, 1.2.0)
rest-open-uri (1.0.0)
rspec (1.3.0)
rspec-rails (1.3.2)
rubyforge (2.0.3)
rubygems-update (1.3.5)
russian (0.2.5)
sinatra (0.9.4)
soap4r (1.5.8)
sqlite3-ruby (1.2.5)
term-ansicolor (1.0.4)
test-unit (1.2.3)
treetop (1.4.3)
unicode_utils (1.0.0)
webrat (0.7.0)
ZenTest (4.2.1)

=end


Files

house_searches_test.rb (875 Bytes) house_searches_test.rb sergeykish (Sergey Kish), 02/12/2010 04:44 AM

History

#1

Updated by sergeykish (Sergey Kish) about 9 years ago

=begin
I'm sorry - it works good recompiled from source.
Looks like it was caused by blocked packages.
Please close the report.
=end

#2

Updated by matz (Yukihiro Matsumoto) almost 9 years ago

  • Status changed from Open to Closed

=begin

=end

Also available in: Atom PDF