Project

General

Profile

Actions

Bug #286

closed

open-uri leaking file handles

Added by Anonymous about 13 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]
[ruby-core:17824]

Description

=begin
With some requests (particularly status 404 from Amazon.com), the reference to the temp file used to buffer the response is lost and left open, causing failure in long running processes. Temp file remains after process is killed.

attached script contains example repro.
=end


Files

openuritest.rb (1.35 KB) openuritest.rb Anonymous, 07/18/2008 09:26 AM
Actions #1

Updated by nobu (Nobuyoshi Nakada) about 13 years ago

=begin
Hi,

At Fri, 18 Jul 2008 09:21:46 +0900,
Anonymous wrote in [ruby-core:17824]:

Target version:

Which version?

With some requests (particularly status 404 from Amazon.com),
the reference to the temp file used to buffer the response is
lost and left open, causing failure in long running
processes. Temp file remains after process is killed.

attached script contains example repro.

I couldn't reproduce it with your script and latest 1.8.

--
Nobu Nakada

=end

Actions #2

Updated by Anonymous about 13 years ago

=begin
Produced in 1.8.2 and 1.8.6p36.
=end

Actions #3

Updated by Anonymous about 13 years ago

=begin
adding -v 1.8.2 on MacOS 10.4, and -v 1.8.6p36 on Fedora 8.
=end

Actions #4

Updated by curi (Elliot Temple) almost 13 years ago

=begin
I can duplicate the bug on OS X 10.5

ruby 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]

=end

Actions #5

Updated by akr (Akira Tanaka) over 12 years ago

  • Assignee set to akr (Akira Tanaka)

=begin

=end

Actions #6

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • ruby -v set to ruby 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]

=begin
Those files get removed at process termination, so it doesn't "leak" truely.
=end

Actions #7

Updated by akr (Akira Tanaka) about 12 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
Applied in changeset r24902.
=end

Actions

Also available in: Atom PDF