Project

General

Profile

Backport #3661

win32/api.so: [BUG] Segmentation fault

Added by newmonkey (Sylvain Pelissier) almost 9 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
[ruby-core:31635]

Description

=begin
I run 'gem install win32-process' on Windows 7 64-bit and it comes with a win32-api that is pre-compiled for x86 machines. I don't know for sure if this is the best place to request such thing but I would like to have a pre-compiled version of that library for my OS.

Context: I am using selenium web driver (selenium-server-standalone-2.0a5.jar) from within Eclipse Galileo, including DLTK 2.0. This enables me to create ruby scripts to automate/drive web browsers.

Problem: It's working fine under ruby 1.8.7, but if I use ruby 1.9.1, then I get a seg fault (see attached). According to the only post I found in the Internet, this is because the win32-api libraries I can access via ruby gem is pre-compiled with x86 machines in mind. I have not found anywhere the library for a 64 bit Windows OS. And I am not sure how to compile it from source under Windows...

Solution: when I run the command gem install win32-process on this 64-bit Windows 7 machine, I should get the files for the corresponding architecture.

-Thank you-
=end


Files

win64_ruby9_win32-api.segfault (5.21 KB) win64_ruby9_win32-api.segfault newmonkey (Sylvain Pelissier), 08/06/2010 11:36 PM

History

#1

Updated by luislavena (Luis Lavena) almost 9 years ago

=begin
This is a 3rd party issue.

win32-utils bugs should be reported to their project:

http://rubyforge.org/projects/win32utils/

And one of the developers with the Git repositories is at GitHub:

http://github.com/djberg96

Look over there and provide him a patch.

Your issue is actually that the binary is linked to Ruby 1.8 and not 1.9, the internal Ruby API changes can generate a segfault when a 1.8 extension is executed under 1.9.

=end

#2

Updated by nobu (Nobuyoshi Nakada) almost 9 years ago

  • Status changed from Open to Rejected

=begin

=end

#3

Updated by newmonkey (Sylvain Pelissier) almost 9 years ago

=begin
I'm fine with that. Thanks for your help.
=end

Also available in: Atom PDF