Project

General

Profile

Backport #3959

Ruby 1.9.2p0 Segmentation fault under Linux x64 with rvm

Added by ajmurmann (Alexander Murmann) almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:32836]

Description

=begin
I often get segmentation faults when running rspec against my app, when it has errors. The segmentation faults seem to happen when an error should have been thrown instead.

The full stack trace is attached.
=end


Files

ruby_segfault.txt (16.4 KB) ruby_segfault.txt ajmurmann (Alexander Murmann), 10/18/2010 09:15 AM

Related issues

Is duplicate of Backport192 - Backport #3910: SEGV at fptr_finalizeClosed10/06/2010Actions
Is duplicate of Backport192 - Backport #3951: Seg Fault with Rails 3 and UnicornClosed10/16/2010Actions

Associated revisions

Revision 29564
Added by yugui (Yuki Sonoda) almost 9 years ago

merges r29415 from trunk into ruby_1_9_2. fixes #3910 #3951 and #3959.

  • io.c (fptr_finalize): write_mutex might have been destroyed already in finalization phase, as the order of finalizers is not guaranteed. rb_mutex_t should be used in place of Mutex object in the future.

History

#2

Updated by naruse (Yui NARUSE) almost 9 years ago

=begin
Can you show reproducible code?
Can you show gdb backtrace or build with gcc -g option?
=end

#3

Updated by ajmurmann (Alexander Murmann) almost 9 years ago

=begin
I just compiled ruby-1.9.2-head with the -g option order to produce the debug information you requested and the segmentation fault does not occur anymore, so i assume the issue (whatever it was) is solved in head.

Please let me know if you still want me to test it against p0 with -g option.
=end

#4

Updated by naruse (Yui NARUSE) almost 9 years ago

=begin
r29415 may fix this bug, but ruby-1.9.2-head doesn't includes it yet.
So you might try ruby-head, didn't you?
=end

#5

Updated by naruse (Yui NARUSE) almost 9 years ago

  • Status changed from Open to Closed

=begin

=end

Also available in: Atom PDF