Project

General

Profile

Backport #4200

minitest 2.0.2 on trunk

Added by zenspider (Ryan Davis) over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:33864]

Description

=begin
Please merge minitest 2.0.2 on trunk to 1_9_2. This requires the test/unit wrapper to me merged as well, if it hasn't been already.

Paths:

lib/minitest/*
lib/test/unit.rb
lib/test/unit/*
test/minitest/*
=end

History

#1

Updated by zenspider (Ryan Davis) over 8 years ago

=begin
May I do this?
=end

#2

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)

=begin

=end

#3

Updated by yugui (Yuki Sonoda) over 8 years ago

=begin
On Wed, Jan 5, 2011 at 2:01 PM, Ryan Davis redmine@ruby-lang.org wrote:

May I do this?

I don't want merge any enhancement into ruby_1_9_2. So I hesitated to
merge minitest 2.0.2. Sorry for replying so late.
I will merge only bug fixes later. Or you can do it by yourself.

--
Yuki Sonoda (Yugui)
yugui@yugui.jp
http://yugui.jp

=end

#4

Updated by zenspider (Ryan Davis) over 8 years ago

=begin

On Jan 5, 2011, at 00:41 , Yugui wrote:

On Wed, Jan 5, 2011 at 2:01 PM, Ryan Davis redmine@ruby-lang.org wrote:

May I do this?

I don't want merge any enhancement into ruby_1_9_2. So I hesitated to
merge minitest 2.0.2. Sorry for replying so late.
I will merge only bug fixes later. Or you can do it by yourself.

Lucas? Is that you??

Enhancements are mostly in separate files. Leave out minitest/benchmark.rb and that's most of it. I did add some assertions since 1.6.0 (2010-03-27) but it is mostly bug fixes and refactorings.

Here are relevant changes:

=== 2.0.2 / 2010-12-24

  • 1 minor enhancement:

    • Completed doco on minitest/benchmark for specs.
  • 1 bug fix:

    • Benchmarks in specs that didn't call bench_range would die. (zzak).

=== 2.0.1 / 2010-12-15

  • 4 minor enhancements:

    • Do not filter backtrace if $DEBUG
    • Exit autorun via nested at_exit handler, in case other libs call exit
    • Make options accesor lazy.
    • Split printing of test name and its time. (nurse)
  • 1 bug fix:

    • Fix bug when T is hit before runner start

=== 2.0.0 / 2010-11-11

  • 3 major enhancements:

    • Added minitest/benchmark! Assert your performance! YAY!
    • Refactored runner to allow for more extensibility. See minitest/benchmark.
    • This makes the runner backwards incompatible in some ways!
  • 9 minor enhancements:

    • Added MiniTest::Unit.after_tests { ... }
    • Improved output by adding test rates and a more sortable verbose format
    • Improved readme based on feedback from others
    • Added io method to TestCase. If used, it'll supplant '.EF' output.
    • Refactored IO in MiniTest::Unit.
    • Refactored _run_anything to _run_suite to make it easier to wrap (ngauthier)
    • Spec class names are now the unmunged descriptions (btakita)
    • YAY for not having redundant rdoc/readmes!
    • Help output is now generated from the flags you passed straight up.
  • 4 bug fixes:

    • Fixed scoping issue on minitest/mock (srbaker/prosperity)
    • Fixed some of the assertion default messages
    • Fixes autorun when on windows with ruby install on different drive (larsch)
    • Fixed rdoc output bug in spec.rb

=== 1.7.2 / 2010-09-23

  • 3 bug fixes:

    • Fixed doco for expectations and Spec.
    • Fixed test_capture_io on 1.9.3+ (sora_h)
    • assert_raises now lets MiniTest::Skip through. (shyouhei)

=== 1.7.1 / 2010-09-01

  • 1 bug fix:

    • 1.9.2 fixes for spec tests

=== 1.7.0 / 2010-07-15

  • 5 minor enhancements:

    • Added assert_output (mapped to must_output).
    • Added assert_silent (mapped to must_be_silent).
    • Added examples to readme (Mike Dalessio)
    • Added options output at the top of the run, for fatal run debugging (tenderlove)
    • Spec's describe method returns created class

=end

#5

Updated by yugui (Yuki Sonoda) over 8 years ago

=begin
Hi Ryan,

I have merged bug fixes in MiniTest. It is harder than what I thought.

  • I did not import lib/minitest/benchmark.rb because it is a new feature.
  • I suspect the change in lib/minitest/mock.rb is to merge. I agree that the minitest/mock.rb before 5916 had had a wrong design. But 5916 changes minitest/mock's behavior anyway.
  • I merged a part of changes for test/minitest/test_mini_mock.rb. I did not merge the rest of the changes which depends on 5916.
  • I did not import lib/minitest/pride.rb because it seems a new feature.
  • I did not import lib/minitest/spec.rb because its change consits of:
    • minor feature change in Module#infect_with_assetions (sorting)
    • debug print? (Module#infect_with_assertions)
    • refactoring (relocation of calling #infect_with_assertions)
    • following a new feature (calling #infact_with_assertions for assert_silent)
    • feature change (Kernel#describe)
    • adding rdocs (Module#infect_with_assertions, MiniTest::Spec, ...)

I do not merge any rdoc change into ruby_1_9_2 except fixing a
terribly confusing description.

  • MiniTest::Unit
    • I did not merge 5783 because it only adds new features.
    • I did not merge 5785 because it only updated the version. I think we should not update the version because I never add new feature into ruby_1_9_2 so minitest in ruby_1_9_2 is not 1.7.0.
    • I did not merge 5835 because of the same reason.
    • I merged a part of 5875 because it is a bug. Once I decided not to merge shyouhei's fix because I regarded it as a limitation of minitest 1.6.0 that MiniTest::Skip broke the assersion. It was a wrong decision.
    • I did not merge 5877 because it just updated the version.
    • I did not merge 5884 because it changed behavior.
    • I did not merge 5886 because it is an enhancement and a refactoring.
    • I did not merge 5889 because it is a fix for a bug in 5886.
    • I did not merge 5905 because it seemed something related to 5886.
    • I did not merge 5906 because it updated the version.
    • I did not merge 5908 because it added a new feature.
    • I did not merge 5911 because it was a refactoring related to 5908.
    • I did not merge 5913 because it was a refactoring related to 5908.
    • I did not merge 5918 because it only affects Ruby 1.8 or eariler. By the way, I think the condition should be RUBY_VERSION >= "1.9".
    • I did not merge 5922 because it was a refactoring.
    • I did not merge 5923 because it contained only style changes.
    • I did not merge 5924 because it was a refactoring.
    • I did not merge 5926 because it was a refactoring + adding after_tests{ }.
    • I merged only a part of 5937 which fixed some messages.
    • I did not merge 5939 because it was a typo.
    • I did not merge 5944 because there is not README.txt for MiniTest in Ruby's repository.
    • I did not merge 5945 because it was a rdoc fix.
    • I did not merge 5948 because I did not merge the latter half of 5937.
    • I did not merge 5951 because it just updated the version.
    • I did not merge 6056 becuase it is a minor feature change and only affects on $DEBUG == true
    • I merged 5907
    • I did not merge 6058 because I did not merge 5901.
    • I did not merge 6059 because I did not merge 5901.
    • I did not merge 6072 because it was a minor improvement, not a bug.
    • I did not merge 6079 because it just updated the version.
    • I did not merge 6093 becuase of the same reason.
    • I did not merge 6095 because it is for Ruby 1.9.3.

--
Yuki Sonoda (Yugui)
yugui@yugui.jp
http://yugui.jp

=end

#6

Updated by yugui (Yuki Sonoda) over 8 years ago

  • Status changed from Assigned to Closed

=begin

=end

#7

Updated by jonforums (Jon Forums) over 8 years ago

=begin
Could the differences between MiniTest 2.0.2 merged into ruby_1_9_2 and MiniTest 2.0.2 available as a standalone RubyGem cause issues similar to RubyGems 1.3.7?

Jon
=end

Also available in: Atom PDF