Project

General

Profile

Actions

Backport #4861

closed

Backport r31528 to 1.9.2

Added by 13k (Kiyoshi Murata) almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:36903]

Description

I see r31346 was merged but it actually has no effect on the issue (#4556) since the code isn't using the generated HAVE_* defines to check for SSLv2.


Related issues 1 (0 open1 closed)

Related to Ruby master - Feature #4556: Please add option which enable SSLv2 supportClosed04/06/2011Actions
Actions #1

Updated by naruse (Yui NARUSE) almost 11 years ago

  • Project changed from Ruby master to Backport192
  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)
Actions #2

Updated by yugui (Yuki Sonoda) almost 11 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r32382.
Kiyoshi, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


merges r31528 from trunk into ruby_1_9_2. fixes #4861.

    * ext/openssl/ossl_ssl.c: By trunk@31346, function check of SSLv2 is executed.
    However, the problem is not revised in this.
    This adds the control of using function of SSLv2 in made macro by function check.
Actions

Also available in: Atom PDF