Project

General

Profile

Backport #6080

fails to define RUBY_FUNC_EXPORTED when compiled with clang

Added by john_firebaugh (John Firebaugh) over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:42875]

Description

When compiling with clang, configure fails the checking for exported function attribute step and therefore does not generate a define for RUBY_FUNC_EXPORTED. This causes 3rd party gems such as ruby-debug-base to fail due to missing symbols.

Here is the relevant configure.log output:

https://gist.github.com/1904618

I am not sure why configure decided that the first program, using __attribute__ ((visibility("default"))), failed. It successfully compiled and is correct.


Related issues

Is duplicate of Backport193 - Backport #6064: unsupported -ggdb flag is used with clang 3.1Closed02/23/2012Actions

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Category set to build
  • Assignee set to nobu (Nobuyoshi Nakada)
  • Target version set to 2.0.0
#2

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r34840.
John, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • configure.in (debugflags): check if -ggdb is accepted. [ruby-core:42875][Bug #6080]
#3

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Tracker changed from Bug to Backport
  • Project changed from Ruby master to Backport193
  • Category deleted (build)
  • Target version deleted (2.0.0)

Also available in: Atom PDF