Backport #6314

Backport r35374 and r35375

Added by Eric Hodel over 3 years ago. Updated over 3 years ago.

[ruby-core:44431]
Status:Closed
Priority:Normal
Assignee:-

Description

=begin
This will update 1.9.3 to RubyGems 1.8.22 which is primarily bug fixes or interoperability and performance enhancements. The full list of updates since 1.8.11 follows:

=== 1.8.22 / 2012-04-13

  • 4 bug fixes:

    • Workaround for psych/syck YAML date parsing issue
    • Don't trust the encoding of ARGV. Fixes #307
    • Quiet default warnings about missing spec variables
    • Read a binary file properly (windows fix)

=== 1.8.21 / 2012-03-22

  • 2 bug fixes:

    • Add workaround for buggy yaml output from 1.9.2
    • Force 1.9.1 to remove it's prelude code. Fixes #305

=== 1.8.20 / 2012-03-21

  • 4 bug fixes:

    • Add --force to gem build to skip validation. Fixes #297
    • Gracefully deal with YAML::PrivateType objects in Marshal'd gemspecs
    • Treat the source as a proper url base. Fixes #304
    • Warn when updating the specs cache fails. Fixes #300

=== 1.8.19 / 2012-03-14

  • 3 bug fixes:

    • Handle loading psych vs syck properly. Fixes #298
    • Make sure Date objects don't leak in via Marshal
    • Perform Date => Time coercion on yaml loading. Fixes #266

=== 1.8.18 / 2012-03-11

  • 4 bug fixes:

    • Use Psych API to emit more compatible YAML
    • Download and write inside gem fetch directly. Fixes #289
    • Honor sysconfdir on 1.8. Fixes #291
    • Search everywhere for a spec for gem spec. Fixes #288
    • Fix Gem.all_load_path. Fixes #171

=== 1.8.17 / 2012-02-17

  • 2 minor enhancements:

    • Add MacRuby to the list of special cases for platforms (ferrous26)
    • Add a default for where to install rubygems itself
  • 3 bug fixes:

    • Fixed gem loading issue caused by dependencies not resolving.
    • Fixed umask error when stdlib is required and unresolved dependencies exist.
    • Shebang munging would only take one arg after the cmd
    • Define SUCKAGE better, ie only MRI 1.9.2
    • Propagate env-shebang to the pristine command if set for install.

=== 1.8.16 / 2012-02-12

  • 3 bug fixes:

    • Fix gem specification loading when encoding is not UTF-8. #146
    • Allow group writable if umask allows it already.
    • Uniquify the spec list based on directory order priority

=== 1.8.15 / 2012-01-06

  • 1 bug fix:

    • Don't eager load yaml, it creates a bad loop. Fixes #256

=== 1.8.14 / 2012-01-05

  • 2 bug fixes:

    • Ignore old/bad cache data in Version
    • Make sure our YAML workarounds are loaded properly. Fixes #250.

=== 1.8.13 / 2011-12-21

  • 1 bug fix:

    • Check loaded_specs properly when trying to satisfy a dep
  • 2 minor enhancements:

    • Remove using #loaded_path? for performance
    • Remove Zlib workaround for Windows build.

=== 1.8.12 / 2011-12-02

  • Bug fix:
    • Handle more cases where Syck's DefaultKey showed up in requirements and wasn't cleaned out.

=end

History

#2 Updated by Evan Phoenix over 3 years ago

Looks good to me.

--
Evan Phoenix // evan@phx.io

On Thursday, April 19, 2012 at 11:15 AM, drbrain (Eric Hodel) wrote:

Issue #6314 has been updated by drbrain (Eric Hodel).

Commits are:

https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/35374

https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/35375

Backport #6314: Backport r35374 and r35375
https://bugs.ruby-lang.org/issues/6314#change-26009

Author: drbrain (Eric Hodel)
Status: Open
Priority: Normal
Assignee:
Category:
Target version:

=begin
This will update 1.9.3 to RubyGems 1.8.22 which is primarily bug fixes or interoperability and performance enhancements. The full list of updates since 1.8.11 follows:

=== 1.8.22 / 2012-04-13

  • 4 bug fixes:

  • Workaround for psych/syck YAML date parsing issue

  • Don't trust the encoding of ARGV. Fixes #307

  • Quiet default warnings about missing spec variables

  • Read a binary file properly (windows fix)

=== 1.8.21 / 2012-03-22

  • 2 bug fixes:

  • Add workaround for buggy yaml output from 1.9.2

  • Force 1.9.1 to remove it's prelude code. Fixes #305

=== 1.8.20 / 2012-03-21

  • 4 bug fixes:

  • Add --force to gem build to skip validation. Fixes #297

  • Gracefully deal with YAML::PrivateType objects in Marshal'd gemspecs

  • Treat the source as a proper url base. Fixes #304

  • Warn when updating the specs cache fails. Fixes #300

=== 1.8.19 / 2012-03-14

  • 3 bug fixes:

  • Handle loading psych vs syck properly. Fixes #298

  • Make sure Date objects don't leak in via Marshal

  • Perform Date => Time coercion on yaml loading. Fixes #266

=== 1.8.18 / 2012-03-11

  • 4 bug fixes:

  • Use Psych API to emit more compatible YAML

  • Download and write inside gem fetch directly. Fixes #289

  • Honor sysconfdir on 1.8. Fixes #291

  • Search everywhere for a spec for gem spec. Fixes #288

  • Fix Gem.all_load_path. Fixes #171

=== 1.8.17 / 2012-02-17

  • 2 minor enhancements:

  • Add MacRuby to the list of special cases for platforms (ferrous26)

  • Add a default for where to install rubygems itself

  • 3 bug fixes:

  • Fixed gem loading issue caused by dependencies not resolving.

  • Fixed umask error when stdlib is required and unresolved dependencies exist.

  • Shebang munging would only take one arg after the cmd

  • Define SUCKAGE better, ie only MRI 1.9.2

  • Propagate env-shebang to the pristine command if set for install.

=== 1.8.16 / 2012-02-12

  • 3 bug fixes:

  • Fix gem specification loading when encoding is not UTF-8. #146

  • Allow group writable if umask allows it already.

  • Uniquify the spec list based on directory order priority

=== 1.8.15 / 2012-01-06

  • 1 bug fix:

  • Don't eager load yaml, it creates a bad loop. Fixes #256

=== 1.8.14 / 2012-01-05

  • 2 bug fixes:

  • Ignore old/bad cache data in Version

  • Make sure our YAML workarounds are loaded properly. Fixes #250.

=== 1.8.13 / 2011-12-21

  • 1 bug fix:

  • Check loaded_specs properly when trying to satisfy a dep

  • 2 minor enhancements:

  • Remove using #loaded_path? for performance

  • Remove Zlib workaround for Windows build.

=== 1.8.12 / 2011-12-02

  • Bug fix:
  • Handle more cases where Syck's DefaultKey showed up in requirements and wasn't cleaned out.

=end

http://bugs.ruby-lang.org/

#3 Updated by Yui NARUSE over 3 years ago

  • Status changed from Open to Closed

Backported at r35402

Also available in: Atom PDF