Backport #7162

Need PRI_LL_PREFIX in Ruby 1.9.3 P286

Added by ray linn over 1 year ago. Updated over 1 year ago.

[ruby-core:47996]
Status:Closed
Priority:Normal
Assignee:-

Description

Here is my configuration using MinGW6 with MSYS

./configure --build=x8664-w64-mingw32 CFLAGS="-O3 -finline-functions -I/usr/local/include -I/mingw/mingw/include -DUSEMINGWANSISTDIO" LDFLAGS="-L/usr/local/lib"

but found the #define PRILLPREFIX "ll" exists in P194, but missing in P286. That cause several file compiled failed in P286.

add the define in the config.h , the compile can be continued

History

#1 Updated by Hiroshi Shirosaki over 1 year ago

-D_USEMINGWANSISTDIO would not be needed.

I have the following in config.h with mingw build.

#define PRILLPREFIX "I64"

Backport #7011 changed that and the behavior is same as trunk.

#2 Updated by Usaku NAKAMURA over 1 year ago

  • Status changed from Open to Closed

So, this is not a bug.

Also available in: Atom PDF