Backport #7415


Cygwin doesn't install ruby 1.9.3-p327. Needs access to _wcsicmp glibc library

Added by werp (Paul Werger) almost 9 years ago. Updated over 8 years ago.



I've been trying to install Ruby 1.9.3-p327 in my Cygwin environment. No can do! I run Cygwin on Windows 7 (64 bit) on a Dell laptop. I get the following message in my C:\cygwin\home\PWerger.rvm\log\ruby-1.9.3-p327\make.log: (Please note that earlier version of Ruby 1.9.3 install easily and correctly in my Cygwin environment.)

CC = gcc
LD = ld
LDSHARED = gcc -shared 
CFLAGS = -O3 -ggdb -Wall -Wextra -Wno-unused-parameter -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers -Werror=pointer-arith -Werror=write-strings -Werror=declaration-after-statement -Werror=implicit-function-declaration 
XCFLAGS = -include ruby/config.h -include ruby/missing.h -DRUBY_EXPORT
CPPFLAGS =   -I/home/PWerger/.rvm/usr/include -I. -I.ext/include/i386-cygwin -I./include -I.
DLDFLAGS = -Wl,--enable-auto-image-base,--enable-auto-import -Wl,--out-implib=libruby191.dll.a cygruby191.def  
SOLIBS = cygruby191.res.o -lpthread -lrt -ldl -lcrypt  

linking miniruby.exe
file.o:file.c:(.text+0x41af): undefined reference to _wcsicmp'
collect2: ld returned 1 exit status
Makefile:164: recipe for target
miniruby.exe' failed
make: *** [miniruby.exe] Error 1


make.log (827 Bytes) make.log werp (Paul Werger), 11/21/2012 06:14 AM
configure.log (15.9 KB) configure.log werp (Paul Werger), 11/21/2012 06:14 AM

Updated by phasis68 (Heesob Park) almost 9 years ago

I guess this is 1.9.3-p327 specific issue.

I think r34871 should be backported.
Or STRCASECMP can be used instead of wcsicmp.

Actions #2

Updated by usa (Usaku NAKAMURA) almost 9 years ago

  • Tracker changed from Bug to Backport
  • Project changed from Ruby master to Backport193
  • Category deleted (build)
  • Status changed from Open to Assigned
  • Assignee changed from werp (Paul Werger) to usa (Usaku NAKAMURA)
  • Target version deleted (1.9.3)

Thank you for reporting, Paul.
And thank you for resolving, Park-san.

Actions #3

Updated by usa (Usaku NAKAMURA) over 8 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r38471.
Paul, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

merge revision(s) 34871: [Backport #7415]

* file.c (file_expand_path): use wcscasecmp().

Also available in: Atom PDF