Project

General

Profile

Bug #768

Mathn's Rational#power2 is broken on 1.8.6 and 1.8.7

Added by jredville (Jim Deville) over 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
[ruby-core:20009]

Description

=begin
Mathn's Rational#power2 method is broken in multiple places.

  1. The loop has no variant, it can go into an infinite loop, unless the conditional is true from the start.
  2. 1.8.6 still has the neaed typo (Redmine #175)
  3. assignment to nearn on line 208
  4. Construction of a Rational with 2 non-existant variables: num and den (dem is used, but not den)

Some test cases that demonstrate the broken code:
(Rational.new!(1, 4).power2(Rational.new!(1, 2))) #(NameError for neaed)
(Rational.new!(3, 4).power2(Rational.new!(0, 3))) #Infinite loop
=end


Related issues

Is duplicate of Ruby 1.8 - Bug #769: Mathn's Rational#power2 is broken on 1.8.6 and 1.8.7Closed11/21/2008Actions
#1

Updated by jredville (Jim Deville) over 11 years ago

=begin
This is a dup of 769. Please close.
=end

#2

Updated by matz (Yukihiro Matsumoto) over 11 years ago

  • Status changed from Open to Closed

=begin

=end

Also available in: Atom PDF