Backport #8020

make-snapshot fails since r39221

Added by Heesob Park about 1 year ago. Updated 12 months ago.

[ruby-core:53141]
Status:Closed
Priority:Normal
Assignee:Tomoyuki Chikanaga

Description

$ ruby tool/make-snapshot /tmp/snapshopt trunk@39221
Exporting trunk@39221
Exported revision 39221.
take a breath, and go ahead
creating configure...configure:1507: error: possibly undefined macro: m4textwrapword
If this token and others are legitimate, please use m4patternallow.
See the Autoconf documentation.
failed

$ autoconf --version
autoconf (GNU Autoconf) 2.64
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv2+: GNU GPL version 2 or later
http://gnu.org/licenses/old-licenses/gpl-2.0.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by David J. MacKenzie and Akim Demaille.

Autoconf 2.50 chosen by Debian wrapper script.
For information and tuning advice see autoconf(1).

I am not sure where it is related to the same issue, the Nightly Snapshot(ftp://ftp.ruby-lang.org/pub/ruby/snapshot.tar.gz) is not generated since 2013/02/28 04:09:14.


Related issues

Related to Backport200 - Backport #8192: [OSX] Build failure by trunk Closed 03/31/2013

Associated revisions

Revision 40489
Added by Tomoyuki Chikanaga 12 months ago

  • configure.in: use quadrigraphs. workaround for autoconf 2.64. a patch provided by Hessob Park. [Backport #8020]

History

#1 Updated by Nobuyoshi Nakada about 1 year ago

I could make snapshots r39601.

#2 Updated by Heesob Park about 1 year ago

This issue only occurs with autoconf 2.64.
The workaround is using quadrigraphs.

Here is a patch:
diff --git a/configure.in b/configure.in.new
index 4d6d6ed..b4f11b7 100644
--- a/configure.in
+++ b/configure.in.new
@@ -625,7 +625,7 @@ ACARGENABLE(werror,
ASHELPSTRING([--disable-werror],
[don't make warnings into errors
even if a compiler support -Werror feature
- [[disabled by default unless development version]]]),
+ @<:@disabled by default unless development version@:>@]),
[particularwerrorflags=$enableval])

rbcvwarnflags="$warnflags"

#3 Updated by Nobuyoshi Nakada about 1 year ago

  • Status changed from Open to Closed

Fixed at r40034.

#4 Updated by Nobuyoshi Nakada about 1 year ago

  • Tracker changed from Bug to Backport
  • Project changed from ruby-trunk to Backport200
  • Status changed from Closed to Assigned
  • Assignee set to Tomoyuki Chikanaga

#5 Updated by Tomoyuki Chikanaga about 1 year ago

Hello, nobu.

How do you think about Hessob's workaround patch?
I hesitate to backport the change about requires autoconf version.
Mac OS X Lion's preinstalled autoconf is 2.61.

#6 Updated by Tomoyuki Chikanaga 12 months ago

nobu told me that this problem occurs only when use both ACARGENABLE and ACHELPSTRING.
https://twitter.com/n0kada/status/326982877210353664 (in Japanese).
Thank you nobu.

Upgrade required version of autoconf prevent smooth install on some platforms still used widely (Lion, CentOS 6.3).
I'll merge Hessob's patch by hand.

#7 Updated by Tomoyuki Chikanaga 12 months ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r40489.
Heesob, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • configure.in: use quadrigraphs. workaround for autoconf 2.64. a patch provided by Hessob Park. [Backport #8020]

Also available in: Atom PDF