Backport #8171

build of ruby-2.0.0-p0 fails under Mac OS X 10.8.3

Added by Robert Poor about 1 year ago. Updated about 1 year ago.

[ruby-core:53750]
Status:Closed
Priority:Normal
Assignee:-

Description

Compilation of a fresh download of ruby-2.0.0-p0.tar.gz fails while attempting to link miniruby, specifically:

...
compiling ./missing/setproctitle.c
compiling dmyext.c
linking miniruby
.../ruby-2.0.0-p0/lib/fileutils.rb:111: [BUG] Stack consistency error (sp: 38, bp: 36)

Compilation environment:

MacBook Pro
OS X 10.8.3
Xcode version 4.6.1 with command line tools
gcc version 4.2.1 (Based on Apple Inc. build 5658)

Compilation commands:

$ ./configure --prefix=${INSTALLDIR} --enable-shared --disable-install-doc --with-opt-dir=${INSTALLDIR}
$ make

Full details are in https://gist.github.com/rdpoor/5249186


Related issues

Duplicates Backport200 - Backport #8118: backport r39806 Closed 03/19/2013

History

#1 Updated by Nobuyoshi Nakada about 1 year ago

  • Status changed from Open to Closed

#2 Updated by Robert Poor about 1 year ago

Hello Nobu:

I'm glad that the issue is closed. Can you provide any additional information? This was my first bug report to ruby-lang.org and so I would like to know if there was a problem with my bug report. (Was it a duplicate? Was this the wrong place to report this bug? Etc.) And if there was not a problem with my bug report, is there a solution to the error I observed?

Many thanks!

  • Rob

#3 Updated by Nobuyoshi Nakada about 1 year ago

Sorry, no problems with your report.
This issue just duplicates [Backport #8118], which is already finished.
I thought that I've added the duplication, but actually not.

#4 Updated by Robert Poor about 1 year ago

Many thanks for the clarification. I examined the diff in 8118, patched my local version of vm_exec.c and it is now happily compiling away.

Also available in: Atom PDF