Project

General

Profile

Backport #8878

contents of test-unit.gemspec not reproducible

Added by terceiro (Antonio Terceiro) almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:57072]

Description

Because the input gemspec does not contain a date, the generated gemspec will have a different date depending on when Ruby was
compiled.

On Debian we want to support multiarch, and that requires architecture-independent files to be byte-by-byte identical.

The attached patch fixes this by adding an explicit date to the gemspec.


Files


Related issues

Has duplicate Backport200 - Backport #9085: contents of io-console.gemspec not reproducibleClosed11/06/2013Actions

Associated revisions

Revision 55291545
Added by nobu (Nobuyoshi Nakada) almost 6 years ago

rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@42890 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 42890
Added by nobu (Nobuyoshi Nakada) almost 6 years ago

rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Revision 42890
Added by nobu (Nobuyoshi Nakada) almost 6 years ago

rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Revision 42890
Added by nobu (Nobuyoshi Nakada) almost 6 years ago

rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Revision 42890
Added by nobu (Nobuyoshi Nakada) almost 6 years ago

rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Revision 42890
Added by nobu (Nobuyoshi Nakada) almost 6 years ago

rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Revision 42890
Added by nobu (Nobuyoshi Nakada) almost 6 years ago

rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Revision 9aab347c
Added by nagachika (Tomoyuki Chikanaga) almost 6 years ago

merge revision(s) 42890: [Backport #8878]

    * tool/rbinstall.rb (Gem::Specification#initialize): default date to
      RUBY_RELEASE_DATE.  [ruby-core:57072] [Bug #8878]

    * tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_0_0@42946 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 42946
Added by nagachika (Tomoyuki Chikanaga) almost 6 years ago

merge revision(s) 42890: [Backport #8878]

* tool/rbinstall.rb (Gem::Specification#initialize): default date to
  RUBY_RELEASE_DATE.  [ruby-core:57072] [Bug #8878]

* tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Revision 68eb3d86
Added by nagachika (Tomoyuki Chikanaga) over 5 years ago

merge revision(s) 42862(partially),42910,43093: [Backport #8878] [Backport #9085]

    * common.mk: use RUNRUBY instead of MINIRUBY because MINIRUBY can't
      require extension libraries. The patch is from nobu
      (Nobuyoshi Nakada).

    * configure.in (RUNRUBY): append -- only after runruby.rb, not
      cross-compiling baseruby, so that $(RUN_OPT) can be command line
      options.  [ruby-dev:47703] [Bug #8893]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_0_0@43654 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 43654
Added by nagachika (Tomoyuki Chikanaga) over 5 years ago

merge revision(s) 42862(partially),42910,43093: [Backport #8878] [Backport #9085]

* common.mk: use RUNRUBY instead of MINIRUBY because MINIRUBY can't
  require extension libraries. The patch is from nobu
  (Nobuyoshi Nakada).

* configure.in (RUNRUBY): append -- only after runruby.rb, not
  cross-compiling baseruby, so that $(RUN_OPT) can be command line
  options.  [ruby-dev:47703] [Bug #8893]

Revision f4d76649
Added by nagachika (Tomoyuki Chikanaga) over 5 years ago

merge revision(s) 43609,43617: [Backport #8878] [Backport #9085]

    vcs.rb: split

    * tool/vcs.rb: split from file2lastrev.rb.
    * tool/rbinstall.rb (Gem::Specification.load): obtain spec date from
      VCS for the case using git, RUBY_RELEASE_DATE is the last resort.
      probably fixes [Bug #9085].

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_0_0@43655 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 43655
Added by nagachika (Tomoyuki Chikanaga) over 5 years ago

merge revision(s) 43609,43617: [Backport #8878] [Backport #9085]

vcs.rb: split

* tool/vcs.rb: split from file2lastrev.rb.
* tool/rbinstall.rb (Gem::Specification.load): obtain spec date from
  VCS for the case using git, RUBY_RELEASE_DATE is the last resort.
  probably fixes [Bug #9085].

History

Updated by sorah (Sorah Fukumori) almost 6 years ago

  • Category changed from build to lib
  • Status changed from Open to Assigned
  • Assignee changed from nobu (Nobuyoshi Nakada) to sorah (Sorah Fukumori)
#3

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r42890.
Antonio, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


rbinstall.rb: add date

  • tool/rbinstall.rb (Gem::Specification#initialize): default date to RUBY_RELEASE_DATE. [ruby-core:57072] [Bug #8878]
  • tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Updated by terceiro (Antonio Terceiro) almost 6 years ago

Hi, thanks! Can you please backport this to Ruby 2.0?

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: REQUIRED
#6

Updated by nagachika (Tomoyuki Chikanaga) almost 6 years ago

  • Tracker changed from Bug to Backport
  • Project changed from Ruby master to Backport200
  • Category deleted (lib)
  • Status changed from Closed to Assigned
  • Assignee changed from sorah (Sorah Fukumori) to nagachika (Tomoyuki Chikanaga)

Ah, I've overlooked this. Thank you for your notice.

#7

Updated by nagachika (Tomoyuki Chikanaga) almost 6 years ago

  • Status changed from Assigned to Closed

This issue was solved with changeset r42946.
Antonio, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


merge revision(s) 42890: [Backport #8878]

* tool/rbinstall.rb (Gem::Specification#initialize): default date to
  RUBY_RELEASE_DATE.  [ruby-core:57072] [Bug #8878]

* tool/rbinstall.rb (Gem::Specification#to_ruby): add date.

Also available in: Atom PDF