Project

General

Profile

Backport #9306

please backport r44440 and r44444 (build problem of mswin)

Added by usa (Usaku NAKAMURA) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal

Description

current ruby (2.0.0 or later) uses fake.rb for install, but it's broken on mswin.
this problem does not appear with 2.0.0 and 2.1.0, but will do with 2.1.1 (or 2.0.1, when it will be released.)

Associated revisions

Revision f0722322
Added by naruse (Yui NARUSE) over 5 years ago

merge revision(s) 44440,44444: [Backport #9306]

    * win32/Makefile.sub (fake.rb): should depend on version.h because
      if RUBY_VERSION is updated, fake.rb need to say the new version
      to avoid install error in rbconfig.rb.

    * win32/{setup.mak,Makefile.sub}: update fake.rb like
      template/fake.rb.in.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@44532 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 44532
Added by naruse (Yui NARUSE) over 5 years ago

merge revision(s) 44440,44444: [Backport #9306]

* win32/Makefile.sub (fake.rb): should depend on version.h because
  if RUBY_VERSION is updated, fake.rb need to say the new version
  to avoid install error in rbconfig.rb.

* win32/{setup.mak,Makefile.sub}: update fake.rb like
  template/fake.rb.in.

History

#1

Updated by naruse (Yui NARUSE) over 5 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r44532.
Usaku, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


merge revision(s) 44440,44444: [Backport #9306]

* win32/Makefile.sub (fake.rb): should depend on version.h because
  if RUBY_VERSION is updated, fake.rb need to say the new version
  to avoid install error in rbconfig.rb.

* win32/{setup.mak,Makefile.sub}: update fake.rb like
  template/fake.rb.in.

Also available in: Atom PDF