Backport #9375

Backport r44515 RubyGems 2.2.1

Added by Eric Hodel over 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Eric Hodel

Description

This fixes some bugs in RubyGems 2.2.0 including performance regressions.

I have attached a patch to update NEWS as well.

NEWS.rubygems-2.2.1.patch Magnifier - Update NEWS for RubyGems 2.2.1 (514 Bytes) Eric Hodel, 01/07/2014 10:32 AM

Associated revisions

Revision 44778
Added by Yui NARUSE about 1 year ago

merge revision(s) 44515: [Backport #9375]

* lib/rubygems:  Update to RubyGems master 21e409d / RubyGems 2.2.1.
  See http://rubygems.rubyforge.org/rubygems-update/History_txt.html
  for a list of bug fixes.

* test/rubygems:  ditto.

Revision 44786
Added by Yui NARUSE about 1 year ago

Revert r44778 #9375

It breaks test-all if all tests are in a single process

History

#1 Updated by Yui NARUSE about 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Applied in changeset r44778.


merge revision(s) 44515: [Backport #9375]

* lib/rubygems:  Update to RubyGems master 21e409d / RubyGems 2.2.1.
  See http://rubygems.rubyforge.org/rubygems-update/History_txt.html
  for a list of bug fixes.

* test/rubygems:  ditto.

#2 Updated by Yui NARUSE about 1 year ago

  • Status changed from Closed to Assigned
  • Assignee set to Eric Hodel
  • ruby -v set to ruby -v: ruby 2.1.1p13 (2014-01-31 revision 44778) [x86_64-freebsd10.0]

I reverted the merge because it breaks test-all.
http://u32.rubyci.org/~chkbuild/ruby-2.1/log/20140131T191113Z.log.html.gz

#3 Updated by Eric Hodel about 1 year ago

  • Status changed from Assigned to Closed

I tried reproducing on an Ubuntu 12.10 VM but was unable to. I think I see the problem, though. I am committing a possible fix to trunk then will create a new backport ticket for 2.2.2.

Also available in: Atom PDF