Project

General

Profile

Backport #9495

Bacport #8358 - TestSprintf#test_float test failuer

Added by vo.x (Vit Ondruch) about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:60531]

Related issues

Related to Ruby trunk - Bug #8358: TestSprintf#test_float test failureClosed05/02/2013Actions

Associated revisions

Revision c83ad9aa
Added by naruse (Yui NARUSE) about 5 years ago

merge revision(s) 44474,44538,44539,44890,44896: [Backport #9495]

* configure.in: use SSE2 instructions for drop unexpected
  precisions.  [ruby-core:54738] [Bug #8358]

* configure.in: use SSE2 instructions to drop unexpected precisions on
  other than mingw.  [ruby-core:59472] [Bug #8358]

* configure.in: -mstackrealign is necessary for -msse2 working.
  [ruby-core:54716] [Bug #8349]

* configure.in: -mstackrealign is necessary for -msse2 working.
  [ruby-core:54716] [Bug #8349]

* configure.in: add qouting brackets and append wildcard for the
  rest after target_cpu, to properly detect platform for SSE2
  instructions.  [ruby-core:60576] [Bug #8358]

* configure.in: Fix compilation error.
  https://bugs.ruby-lang.org/issues/8358#note-16

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@44993 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 44993
Added by naruse (Yui NARUSE) about 5 years ago

merge revision(s) 44474,44538,44539,44890,44896: [Backport #9495]

* configure.in: use SSE2 instructions for drop unexpected
  precisions.  [ruby-core:54738] [Bug #8358]

* configure.in: use SSE2 instructions to drop unexpected precisions on
  other than mingw.  [ruby-core:59472] [Bug #8358]

* configure.in: -mstackrealign is necessary for -msse2 working.
  [ruby-core:54716] [Bug #8349]

* configure.in: -mstackrealign is necessary for -msse2 working.
  [ruby-core:54716] [Bug #8349]

* configure.in: add qouting brackets and append wildcard for the
  rest after target_cpu, to properly detect platform for SSE2
  instructions.  [ruby-core:60576] [Bug #8358]

* configure.in: Fix compilation error.
  https://bugs.ruby-lang.org/issues/8358#note-16

History

Updated by vo.x (Vit Ondruch) about 5 years ago

Wait ... I opened the backport ticket, but now trying the patch myself, it does not help me for some reason :/

Updated by naruse (Yui NARUSE) about 5 years ago

  • Status changed from Open to Feedback

The revisions to backport are also required.

Updated by vo.x (Vit Ondruch) about 5 years ago

The issue is resolved by 44474, 44538 and 44890

Updated by naruse (Yui NARUSE) about 5 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

Applied in changeset r44993.


merge revision(s) 44474,44538,44539,44890,44896: [Backport #9495]

* configure.in: use SSE2 instructions for drop unexpected
  precisions.  [ruby-core:54738] [Bug #8358]

* configure.in: use SSE2 instructions to drop unexpected precisions on
  other than mingw.  [ruby-core:59472] [Bug #8358]

* configure.in: -mstackrealign is necessary for -msse2 working.
  [ruby-core:54716] [Bug #8349]

* configure.in: -mstackrealign is necessary for -msse2 working.
  [ruby-core:54716] [Bug #8349]

* configure.in: add qouting brackets and append wildcard for the
  rest after target_cpu, to properly detect platform for SSE2
  instructions.  [ruby-core:60576] [Bug #8358]

* configure.in: Fix compilation error.
  https://bugs.ruby-lang.org/issues/8358#note-16

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

  • Related to Bug #8358: TestSprintf#test_float test failure added

Also available in: Atom PDF