Backport #6807

Updated by Nobuyoshi Nakada over 2 years ago

=begin
===

What happened:

I tried to compile on a new Linux systems (Ubuntu 12.04 and a current custom Linux build)

I get the error:

executable host ruby is required. use --with-baseruby option.
make: *** [miniprelude.c] Error 1

===


What I expected:

I expect that ruby should compile.

This is a repeat of bug #3008, 3008, which was closed a couple of years ago. I tried checking out at the exact commit that fixed #3008 3008 and got the same result, so I'm thinking either something has changed outside of ruby since the fix, or possibly the fix never worked for Linux (the comment in the commit says ...for HP UX")?



There are no docs for how to get around this. How can I get ruby on a system if I can't compile ruby?
=end

Back