Project

General

Profile

« Previous | Next » 

Revision 39509

  • lib/rexml/document.rb: move entity_expansion_limit accessor to ...
  • lib/rexml/rexml.rb: ... here to make rexml/text independent from REXML::Document. It causes circular require.
  • lib/rexml/document.rb (REXML::Document.entity_expansion_limit): deprecated.
  • lib/rexml/document.rb (REXML::Document.entity_expansion_limit=): deprecated.
  • lib/rexml/text.rb: add missing require "rexml/rexml" for REXML.entity_expansion_limit. Reported by Robert Ulejczyk. Thanks!!! [ruby-core:52895] [Bug #7961]