Project

General

Profile

« Previous | Next » 

Revision 45064

Added by normal over 5 years ago

gc.c: RB_GC_GUARD should be robust enough for any compiler

  • include/ruby/ruby.h (RB_GC_GUARD): use rb_gc_guarded_ptr_val on non-GCC/MSC
  • gc.c (rb_gc_guarded_ptr_val): rename and adjust argument. RB_GC_GUARD should be robust enough for any compiler. [ruby-core:60816] [Bug #7805]