Project

General

Profile

Activity

From 01/08/2011 to 01/14/2011

01/14/2011

11:20 AM Bug #4277 (Open): Compiler optimizations may lead to premature GC in C code
=begin
It is several months as I had problems with GzipReader that comes with ruby. When processing large amount of ...
qz (Quet Zal)
03:56 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

(2011/01/13 6:52), Jonas Pfenniger (zimbatm) wrote:
> 2011/1/12 Zeno Davatz<redmine@ruby-lang.org>:
...
naruse (Yui NARUSE)

01/13/2011

10:08 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
伊達と申します。

1.8.7 で Rails アプリやツールを作っているユーザです。
1.8.7 がしばらくメンテナンスされるのであれば、1.8.8 はリリースされなくとも構わない派です。

Ruby の将...
date (Ken DATE)
06:47 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
結局1.8.8って誰のためのものなのでしょうね。「出すとすればそれを必要とする人のため」おっしゃるとおり。で、具体的にそれって誰ですか? いなくないですか? という。少なくともこれまでの1.8.[567]に関しては、自...
shyouhei (Shyouhei Urabe)
04:05 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Wed, Jan 12, 2011 at 3:52 PM, Jonas Pfenniger (zimbatm)
<jonas@pfenniger.name> wrote:
> Look. ruby-1.9.2...
headius (Charles Nutter)
06:52 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/12 Zeno Davatz <redmine@ruby-lang.org>:
> So why was the Oniguruma-Patch never applied to 1.8.7 or 1....
zimbatm (zimba tm)
07:39 AM Bug #4273: Inherited hook called after module_eval for Class.new
=begin
Hi,

unfortunately, changing these two lines would break backward-compatibility, which would bring the sa...
zimbatm (zimba tm)

01/12/2011

08:46 PM Bug #4273 (Open): Inherited hook called after module_eval for Class.new
=begin
class Base
def self.inherited(klass)
klass.instance_variable_set(:@x, :base)
end
end

Der...
banister (john mair)
05:14 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Eric

Thanks for your reply.

01/11/2011 08:15 PM - reply to Eric Hodel

So why was the Onig...
zdavatz (Zeno Davatz)
01:55 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
JRuby's 1.9 support is perhaps not complete, but it's good enough that we can run a very high percentage of R...
headius (Charles Nutter)
12:29 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
#####
# This is translation from
# Akinori MUSHA's mail at http://redmine.ruby-lang.org/issues/show/4207#no...
sorah (Sorah Fukumori)
04:15 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Jan 10, 2011, at 23:59, Zeno Davatz wrote:

> I believe that we do need a 1.8.8 Release. The simple reas...
drbrain (Eric Hodel)
02:33 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
2011/1/12 Akinori MUSHA <redmine@ruby-lang.org>:
> ruby 1.8.8devを1.8.8とするためには以下が最低限必要と考えます。
>
> 1. 1.8がMRI...
nahi (Hiroshi Nakamura)
02:05 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/34403
にて、JRubyのheadius氏が

原文:
>JRuby's 1.9 su...
sorah (Sorah Fukumori)
12:43 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
遠藤です。

2011年1月12日10:13 Akinori MUSHA <redmine@ruby-lang.org>:
> 色々と切羽詰まっててまったく議論の方向付けに加われずすみません。

お忙しいとこ...
mame (Yusuke Endoh)
12:33 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
sora_hです。
わかりました。ぎりぎりきづいてよかったです。
ということでruby-coreに投げました。
問題点があれば言ってください。

http://redmine.ruby-lang.org/is...
sorah (Sorah Fukumori)
11:21 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
1の、JRubyのくだりは私の認識不足でした。1.9サポートはまだ発展途上なのですね。
訳してくださる方は、「現在はどうでしょうか。」の段落を除いていただけると助かります。

いちばん言いたいのは2,3を導...
knu (Akinori MUSHA)
10:13 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
色々と切羽詰まっててまったく議論の方向付けに加われずすみません。

ruby 1.8.8devを1.8.8とするためには以下が最低限必要と考えます。

1. 1.8がMRIだけの存在となる環境が整うこと...
knu (Akinori MUSHA)

01/11/2011

05:04 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
とりあえずruby-coreにも書きましたがruby1.8.7が最後で良いと思います。
ruby1.8.8に追加するfeature次第ですが、使いたければ1.9にrvmかなにかでswitchすればいいんではないかと、...
sorah (Sorah Fukumori)
04:50 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
ユーザーを無視するつもりはありませんがとりあえず開発者に関しては、今後に関して
積極的な関心を寄せていただいたのは咳さんだけという現実もあり、概ねの方は興味な
いんだろうなあということは分かりました。ありがとうござ...
shyouhei (Shyouhei Urabe)
04:57 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi

I believe that we do need a 1.8.8 Release. The simple reason for that is: Otherwise the Road to 1.9....
zdavatz (Zeno Davatz)
07:57 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Mon, Jan 10, 2011 at 11:47:14AM +0900, Charles Nutter wrote:
> Issue #4239 has been updated by Charles Nu...
tenderlovemaking (Aaron Patterson)

01/10/2011

04:16 PM Bug #4181: Backport Ruby 1.9 singleton.rb, since 1.8's is not thread-safe
=begin
require 'thread' is required to get Mutex, which the 1.9 version uses to safely define the singleton. I think...
headius (Charles Nutter)
12:13 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Mon, Jan 10, 2011 at 11:45 AM, Charles Nutter <redmine@ruby-lang.org> wrote:
> 1.8.7 is a good release. I...
sorah (Sorah Fukumori)
11:45 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
1.8.7 is a good release. It should be the last 1.8.x release. There's no need to make a "better" 1.8.7 in 1.8...
headius (Charles Nutter)

01/08/2011

10:48 PM Bug #4181: Backport Ruby 1.9 singleton.rb, since 1.8's is not thread-safe
=begin
You mean we should copy 1.9's singleton.rb to 1.8 except "require 'thread'"?
=end
naruse (Yui NARUSE)
 

Also available in: Atom