Project

General

Profile

Activity

From 12/26/2010 to 01/24/2011

01/24/2011

06:14 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Cezary

Thank you for your reply.

As Chuck recommended to me privately I tried to document the ...
zdavatz (Zeno Davatz)

01/23/2011

07:18 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Sun, Jan 23, 2011 at 05:18:05AM +0900, Zeno Davatz wrote:
> Issue #4239 has been updated by Zeno Davatz.
...
Cezary (Cezary Baginski)
05:18 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Rodrigo

Me to, I think it is good if Ruby would change to Git.

Dear Cezary

I think modula...
zdavatz (Zeno Davatz)
02:14 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Jan 22, 2011, at 1:31, Zeno Davatz <redmine@ruby-lang.org> wrote:

> I suggest for the Future that you s...
drbrain (Eric Hodel)

01/22/2011

11:27 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Thu, Jan 20, 2011 at 06:30:29PM +0900, Zeno Davatz wrote:
> Issue #4239 has been updated by Zeno Davatz.
...
Cezary (Cezary Baginski)
09:50 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On 22-01-2011 07:31, Zeno Davatz wrote:
> Issue #4239 has been updated by Zeno Davatz.
>
>
> Dear Matsu...
rosenfeld (Rodrigo Rosenfeld Rosas)
08:34 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hello Zeno,

In a separate thread, you claim that Ruby is inconsistent because it did
not include your fa...
duerst (Martin Dürst)
08:33 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hello Zeno,

In a separate thread, you claim that Ruby is inconsistent because it did
not include your fa...
duerst (Martin Dürst)
06:31 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

Thank you for your reply.

Your question is rhetorical, not practical. No I do no...
zdavatz (Zeno Davatz)
05:57 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Lucas

Now this is interesting:

Quote Lucas N.:
> My problem with the high number of branches...
zdavatz (Zeno Davatz)
10:21 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
I cannot comment on C Ruby 1.9.2 behavior. I also can't comment on the pg gem, since we don't use it for JRub...
headius (Charles Nutter)
06:57 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

In message "Re: [ruby-core:34773] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's need...
matz (Yukihiro Matsumoto)
06:33 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On 22/01/11 at 06:10 +0900, Zeno Davatz wrote:
> Issue #4239 has been updated by Zeno Davatz.
>
>
> Dea...
lucas (Lucas Nussbaum)
06:19 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Mathew

I like that "should" - lets work towards that goal.

According to what Yui Naruse told m...
zdavatz (Zeno Davatz)
06:10 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Chuck

Just for my understanding:

Ruby 1.8.6 is very stable. So is Ruby 1.8.7 less stable then ...
zdavatz (Zeno Davatz)
05:30 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Fri, Jan 21, 2011 at 13:55, Zeno Davatz <redmine@ruby-lang.org> wrote:
> It seems that what you say, I sa...
meta (mathew murphy)
04:55 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Mathew

It seems that what you say, I say as well. I never said that if you write something for Ruby...
zdavatz (Zeno Davatz)
04:22 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Charlie

May I ask you on what OS your system runs on. Do you use the pg gem? If so what version? We...
zdavatz (Zeno Davatz)
03:56 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Fri, Jan 21, 2011 at 12:52 PM, Charles Oliver Nutter
<headius@headius.com> wrote:
> JRuby 1.8 and 1.9 mo...
headius (Charles Nutter)
03:53 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Fri, Jan 21, 2011 at 2:46 AM, Zeno Davatz <redmine@ruby-lang.org> wrote:
> Issue #4239 has been updated b...
headius (Charles Nutter)
03:16 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Fri, Jan 21, 2011 at 10:11, Zeno Davatz <redmine@ruby-lang.org> wrote:
> 2. pg does not work with Ruby 1....
meta (mathew murphy)
03:07 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Thu, Jan 20, 2011 at 03:30, Zeno Davatz <redmine@ruby-lang.org> wrote:
> Consistency should have been bet...
meta (mathew murphy)
02:24 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Austin

Thank you for your Input. I will hardlink it and try to understand better.

In the meant...
zdavatz (Zeno Davatz)
02:00 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Fri, Jan 21, 2011 at 9:42 AM, Zeno Davatz <redmine@ruby-lang.org> wrote:
> Issue #4239 has been updated b...
austin (Austin Ziegler)
01:50 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

I guess I learned a lot of Ruby-Politics today. I would summarize like this:

1. ...
zdavatz (Zeno Davatz)
01:30 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Luis

Do you even run an application that uses the pg gem? No I am not talking about ruby-pg 0.7.9.2...
zdavatz (Zeno Davatz)
01:11 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matthias

I do not want to give the fault to anybody, want to track down why our Application simply ...
zdavatz (Zeno Davatz)
01:06 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

In message "Re: [ruby-core:34747] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's need...
matz (Yukihiro Matsumoto)
12:55 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Fri, Jan 21, 2011 at 12:49 PM, Zeno Davatz <redmine@ruby-lang.org> wrote:
>
> Well just FYI but the pg g...
luislavena (Luis Lavena)
12:49 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

Well just FYI but the pg gem also does not work with Ruby 1.9.2 - it used to work wit...
zdavatz (Zeno Davatz)

01/21/2011

11:43 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi Zeno,

On 21.01.2011 13:57, Zeno Davatz wrote:
> In contrast I have a very simple Use-Case for you. Rub...
mwaechter (Matthias Wächter)
11:38 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Austin

Thank you for your input.

Can you be a bit more specific please or can you point me to ...
zdavatz (Zeno Davatz)
10:30 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
You're looking at 1.9.2 as if the version were major.minor.patch. It isn't, as has been noted in the past.

...
austin (Austin Ziegler)
10:24 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Luis

Long-time no see! Thank you for your Feedback.

Please bring some practical examples to th...
zdavatz (Zeno Davatz)
10:07 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Fri, Jan 21, 2011 at 9:57 AM, Zeno Davatz <redmine@ruby-lang.org> wrote:
>
> In contrast I have a very s...
luislavena (Luis Lavena)
09:57 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Bill

In my opinion you prove to like theory over practice. Ok, the Hash-Iteration happens with big...
zdavatz (Zeno Davatz)
09:40 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Greetings,

NARUSE, Yui wrote:
> 2011/1/21 Bill Kelly <billk@cts.com>:
>> Similarly, I would be vastly co...
spatulasnout (B Kelly)
09:22 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Zeno,

Zeno Davatz wrote:
>
> Do you use Hash-Interations? I don't think so. It does not
> seems so or ...
spatulasnout (B Kelly)
09:22 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/21 Bill Kelly <billk@cts.com>:
> Similarly, I would be vastly concerned, disappointed, disheartened,
...
naruse (Yui NARUSE)
09:20 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/21 Zeno Davatz <redmine@ruby-lang.org>:
> Sorry I do not agree. We do not use Hash-Merge we use the n...
naruse (Yui NARUSE)
08:24 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Bill

Do you make a living of playing the lottery? I do not. I make a living from running ruby Soft...
zdavatz (Zeno Davatz)
08:17 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

Sorry I do not agree. We do not use Hash-Merge we use the normal HashIteration and that is br...
zdavatz (Zeno Davatz)
07:51 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

Zeno Davatz wrote:
>
> This is another thing I learned from Linus Torvalds: Think practical
> don'...
spatulasnout (B Kelly)
07:06 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/21 Zeno Davatz <redmine@ruby-lang.org>:
> Please correct me if I am wrong but in
>
> http://redmine...
naruse (Yui NARUSE)
06:58 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

This is another thing I learned from Linus Torvalds: Think practical don't think theoretica...
zdavatz (Zeno Davatz)
06:56 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/21 Zeno Davatz <redmine@ruby-lang.org>:
> I think you are replacing "old" Ruby with "new" Ruby to fas...
naruse (Yui NARUSE)
06:46 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

Please correct me if I am wrong but in

http://redmine.ruby-lang.org/issues/show/1535
...
zdavatz (Zeno Davatz)
06:40 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/21 Zeno Davatz <redmine@ruby-lang.org>:
> So can we expect a consistent behavior or a patch that fixe...
naruse (Yui NARUSE)
06:18 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

I think you are replacing "old" Ruby with "new" Ruby to fast and with a Top-Down approach. ...
zdavatz (Zeno Davatz)
06:02 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

So what you are saying it that Ruby 1.8.6 is like Kernel 2.4 and Ruby 1.9 is like Kernel 2....
zdavatz (Zeno Davatz)
05:46 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

So can we expect a consistent behavior or a patch that fixes the Hash-Iteration for 1.9.2 a...
zdavatz (Zeno Davatz)
05:39 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/21 Zeno Davatz <redmine@ruby-lang.org>:
> Issue #4239 has been updated by Zeno Davatz.
> I still thi...
naruse (Yui NARUSE)
05:13 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/21 Zeno Davatz <redmine@ruby-lang.org>:
> Issue #4239 has been updated by Zeno Davatz.
>
>
> Dear ...
naruse (Yui NARUSE)
04:50 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

I will try to be helpful with the Trunk development.

I still think it is very i...
zdavatz (Zeno Davatz)
04:32 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

I do not understand. So the Hash-Iteration will/should work again in r26687 as it used to w...
zdavatz (Zeno Davatz)
04:06 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
(2011/01/21 0:53), Zeno Davatz wrote:
> PS: I by far prefer the word consistency to the word compatibility.
...
naruse (Yui NARUSE)
04:02 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

In message "Re: [ruby-core:34669] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's need...
matz (Yukihiro Matsumoto)
04:02 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
(2011/01/21 1:14), Yukihiro Matsumoto wrote:
> |This may be off-topic, please point me to the relevant topic...
naruse (Yui NARUSE)
02:30 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

Thank you for your reply.

I would not cherry-pick the features out of the patche...
zdavatz (Zeno Davatz)
01:15 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Jonas

Thank you for the link. I just updated that link. Thank you for the hint. I still need to le...
zdavatz (Zeno Davatz)
01:15 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
HI,

In message "Re: [ruby-core:34665] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's need...
matz (Yukihiro Matsumoto)
12:53 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

Thank you for your reply.

I am imperfect too ;)

I think the way Ruby decides to ...
zdavatz (Zeno Davatz)
03:51 AM Bug #4139: abort and core dump in ruby 1.8.7-p302
=begin
Similar errors are happening in patch 330:
/usr/local/lib/ruby/1.8/ostruct.rb:83: [BUG] Segmentation fault
...
dtrusty (David Trusty)

01/20/2011

09:39 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

In message "Re: [ruby-core:34650] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's need...
matz (Yukihiro Matsumoto)
08:45 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/20 Zeno Davatz <redmine@ruby-lang.org>:
> When I boot into a new kernel then I do _not_ get a Kernel-...
zimbatm (zimba tm)
07:45 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On 10-01-2011 00:47, Charles Nutter wrote:
> Issue #4239 has been updated by Charles Nutter.
>
>
> 1.8....
rosenfeld (Rodrigo Rosenfeld Rosas)
06:27 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

Consistency should have been between Ruby 1.8 and 1.9. That is why I fight for a Ruby...
zdavatz (Zeno Davatz)
02:52 PM Bug #4295: Time.utc(1960) raises ArgumentError: argument out of range (on Windows)
=begin
Ah, ok then. That makes sense.
=end
ghazel (Greg Hazel)
12:09 PM Bug #4295 (Rejected): Time.utc(1960) raises ArgumentError: argument out of range (on Windows)
=begin
Before 1.9.2, internal representation of Time is platform specific.
It's ruby's spec, not bug.
So, if you...
usa (Usaku NAKAMURA)
11:43 AM Bug #4295 (Rejected): Time.utc(1960) raises ArgumentError: argument out of range (on Windows)
=begin
On Windows:

irb(main):001:0> Time.utc(1960)
ArgumentError: argument out of range
from (irb):...
ghazel (Greg Hazel)
12:13 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
妥協する案をなくすと、三択になったのは妥当だと思います(以前の私の提案では妥協するのも含めて4択だった)。なお本件はここまであまり開発者の関心を得られていない気がするので、私もプラクティカルにはaかなあと思います。
...
shyouhei (Shyouhei Urabe)

01/19/2011

09:12 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
(2011/01/18 0:49), Zeno Davatz wrote:
>> The year 2002 is the night before 1.8 is released, so we decided
>...
naruse (Yui NARUSE)
07:59 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
(2011/01/19 18:55), mathew wrote:
> On Sun, Jan 16, 2011 at 12:26, Rick DeNatale<rick.denatale@gmail.com> w...
naruse (Yui NARUSE)
06:56 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Sun, Jan 16, 2011 at 12:26, Rick DeNatale <rick.denatale@gmail.com> wrote:
> On Sun, Jan 16, 2011 at 12:1...
meta (mathew murphy)
08:52 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

In message "Re: [ruby-core:34557] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's need...
matz (Yukihiro Matsumoto)
06:12 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Wed, Jan 19, 2011 at 12:41:45AM +0900, Zeno Davatz wrote:
> Issue #4239 has been updated by Zeno Davatz.
...
Cezary (Cezary Baginski)
12:41 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Matsumoto-san

Thank you for your reply.

I guess this boils down to the discussion of Micro-Ker...
zdavatz (Zeno Davatz)
08:40 AM Revision 30605: * 2011-01-19
svn
08:40 AM Revision 30604: * win32/win32.c (init_stdhandle): backport mistake of r29382.
some code are needless in ruby 1.8.
[ruby-core:34579]
usa (Usaku NAKAMURA)

01/18/2011

11:23 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/17 Zeno Davatz <redmine@ruby-lang.org>:
> For me it is important to understand _why_ Ruby wants to be...
zimbatm (zimba tm)
02:15 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

In message "Re: [ruby-core:34540] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's need...
matz (Yukihiro Matsumoto)
12:49 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

Thank you for your reply.

> The year 2002 is the night before 1.8 is released, so we d...
zdavatz (Zeno Davatz)
08:25 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
1.8.8を「出す」ことのメッセージ性、JRubyや一般の開発者などへの
影響を考えると、妥協して出すなどということで大義名文は立たない
というのが私の主張です。

1.8.8を誰が使っているんだ、と言...
knu (Akinori MUSHA)

01/17/2011

02:51 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

2011/1/17 Zeno Davatz <redmine@ruby-lang.org>:
> No such discussion, that is interesting but accordin...
naruse (Yui NARUSE)
08:34 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Rick DeNatale wrote:
>
> It's water under the bridge, but 1.8.7 introduced several things which
> broke ap...
spatulasnout (B Kelly)
05:54 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

Thank you for your reply.

First of all I do not want to blame anyone. I want to unders...
zdavatz (Zeno Davatz)
03:42 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
(2011/01/17 3:26), Rick DeNatale wrote:
> On Sun, Jan 16, 2011 at 12:19 PM, NARUSE, Yui<naruse@airemix.jp> ...
naruse (Yui NARUSE)
03:26 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Sun, Jan 16, 2011 at 12:19 PM, NARUSE, Yui <naruse@airemix.jp> wrote:
> (2011/01/17 1:49), Rick DeNatale ...
RickDeNatale (Rick DeNatale)
02:19 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
(2011/01/17 1:49), Rick DeNatale wrote:
> But I think what 'enterprise' users are really looking for is a
>...
naruse (Yui NARUSE)
01:50 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Sat, Jan 15, 2011 at 1:05 PM, NARUSE, Yui <naruse@airemix.jp> wrote:
in response to Zeno Davatz:
> Your ...
RickDeNatale (Rick DeNatale)
09:58 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
伊達と申します。

はてなでアンケートを採ってみました。

http://q.hatena.ne.jp/1295189898

ちょっと設問にミスった感がありますが、議論の参考になればと思いますのでご覧くだ...
date (Ken DATE)

01/16/2011

12:17 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
I don't know much of the details/history here, but maybe a few comments
can help.

On 2011/01/16 3:05, NA...
duerst (Martin Dürst)
03:05 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
(2011/01/16 0:11), Zeno Davatz wrote:
> 1. Can you please point me to the discussion, where Ruby-Core decide...
naruse (Yui NARUSE)
12:11 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Yui-san

Thank you for your reply.

1. Can you please point me to the discussion, where Ruby-Cor...
zdavatz (Zeno Davatz)

01/15/2011

02:29 PM Revision 30553: * 2011-01-15
svn
02:29 PM Revision 30552: * ext/zlib/zlib.c (gzfile_check_footer): ISIZE (Input SIZE) in gzip's header
is the size of uncompressed input data modulo 2^32.
[ruby-core:34481] http://www.ietf.org/rfc/rfc1952.txt
naruse (Yui NARUSE)

01/14/2011

11:20 AM Bug #4277 (Open): Compiler optimizations may lead to premature GC in C code
=begin
It is several months as I had problems with GzipReader that comes with ruby. When processing large amount of ...
qz (Quet Zal)
03:56 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi,

(2011/01/13 6:52), Jonas Pfenniger (zimbatm) wrote:
> 2011/1/12 Zeno Davatz<redmine@ruby-lang.org>:
...
naruse (Yui NARUSE)

01/13/2011

10:08 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
伊達と申します。

1.8.7 で Rails アプリやツールを作っているユーザです。
1.8.7 がしばらくメンテナンスされるのであれば、1.8.8 はリリースされなくとも構わない派です。

Ruby の将...
date (Ken DATE)
06:47 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
結局1.8.8って誰のためのものなのでしょうね。「出すとすればそれを必要とする人のため」おっしゃるとおり。で、具体的にそれって誰ですか? いなくないですか? という。少なくともこれまでの1.8.[567]に関しては、自...
shyouhei (Shyouhei Urabe)
04:05 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Wed, Jan 12, 2011 at 3:52 PM, Jonas Pfenniger (zimbatm)
<jonas@pfenniger.name> wrote:
> Look. ruby-1.9.2...
headius (Charles Nutter)
06:52 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
2011/1/12 Zeno Davatz <redmine@ruby-lang.org>:
> So why was the Oniguruma-Patch never applied to 1.8.7 or 1....
zimbatm (zimba tm)
07:39 AM Bug #4273: Inherited hook called after module_eval for Class.new
=begin
Hi,

unfortunately, changing these two lines would break backward-compatibility, which would bring the sa...
zimbatm (zimba tm)

01/12/2011

08:46 PM Bug #4273 (Open): Inherited hook called after module_eval for Class.new
=begin
class Base
def self.inherited(klass)
klass.instance_variable_set(:@x, :base)
end
end

Der...
banister (john mair)
05:14 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Dear Eric

Thanks for your reply.

01/11/2011 08:15 PM - reply to Eric Hodel

So why was the Onig...
zdavatz (Zeno Davatz)
01:55 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
JRuby's 1.9 support is perhaps not complete, but it's good enough that we can run a very high percentage of R...
headius (Charles Nutter)
12:29 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
#####
# This is translation from
# Akinori MUSHA's mail at http://redmine.ruby-lang.org/issues/show/4207#no...
sorah (Sorah Fukumori)
04:15 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Jan 10, 2011, at 23:59, Zeno Davatz wrote:

> I believe that we do need a 1.8.8 Release. The simple reas...
drbrain (Eric Hodel)
02:33 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
2011/1/12 Akinori MUSHA <redmine@ruby-lang.org>:
> ruby 1.8.8devを1.8.8とするためには以下が最低限必要と考えます。
>
> 1. 1.8がMRI...
nahi (Hiroshi Nakamura)
02:05 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/34403
にて、JRubyのheadius氏が

原文:
>JRuby's 1.9 su...
sorah (Sorah Fukumori)
12:43 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
遠藤です。

2011年1月12日10:13 Akinori MUSHA <redmine@ruby-lang.org>:
> 色々と切羽詰まっててまったく議論の方向付けに加われずすみません。

お忙しいとこ...
mame (Yusuke Endoh)
12:33 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
sora_hです。
わかりました。ぎりぎりきづいてよかったです。
ということでruby-coreに投げました。
問題点があれば言ってください。

http://redmine.ruby-lang.org/is...
sorah (Sorah Fukumori)
11:21 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
1の、JRubyのくだりは私の認識不足でした。1.9サポートはまだ発展途上なのですね。
訳してくださる方は、「現在はどうでしょうか。」の段落を除いていただけると助かります。

いちばん言いたいのは2,3を導...
knu (Akinori MUSHA)
10:13 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
色々と切羽詰まっててまったく議論の方向付けに加われずすみません。

ruby 1.8.8devを1.8.8とするためには以下が最低限必要と考えます。

1. 1.8がMRIだけの存在となる環境が整うこと...
knu (Akinori MUSHA)

01/11/2011

05:04 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
とりあえずruby-coreにも書きましたがruby1.8.7が最後で良いと思います。
ruby1.8.8に追加するfeature次第ですが、使いたければ1.9にrvmかなにかでswitchすればいいんではないかと、...
sorah (Sorah Fukumori)
04:50 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
ユーザーを無視するつもりはありませんがとりあえず開発者に関しては、今後に関して
積極的な関心を寄せていただいたのは咳さんだけという現実もあり、概ねの方は興味な
いんだろうなあということは分かりました。ありがとうござ...
shyouhei (Shyouhei Urabe)
04:57 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
Hi

I believe that we do need a 1.8.8 Release. The simple reason for that is: Otherwise the Road to 1.9....
zdavatz (Zeno Davatz)
07:57 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Mon, Jan 10, 2011 at 11:47:14AM +0900, Charles Nutter wrote:
> Issue #4239 has been updated by Charles Nu...
tenderlovemaking (Aaron Patterson)

01/10/2011

04:16 PM Bug #4181: Backport Ruby 1.9 singleton.rb, since 1.8's is not thread-safe
=begin
require 'thread' is required to get Mutex, which the 1.9 version uses to safely define the singleton. I think...
headius (Charles Nutter)
12:13 PM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
On Mon, Jan 10, 2011 at 11:45 AM, Charles Nutter <redmine@ruby-lang.org> wrote:
> 1.8.7 is a good release. I...
sorah (Sorah Fukumori)
11:45 AM Feature #4239: Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
1.8.7 is a good release. It should be the last 1.8.x release. There's no need to make a "better" 1.8.7 in 1.8...
headius (Charles Nutter)

01/08/2011

10:48 PM Bug #4181: Backport Ruby 1.9 singleton.rb, since 1.8's is not thread-safe
=begin
You mean we should copy 1.9's singleton.rb to 1.8 except "require 'thread'"?
=end
naruse (Yui NARUSE)

01/07/2011

09:36 PM Bug #4181: Backport Ruby 1.9 singleton.rb, since 1.8's is not thread-safe
=begin
FYI, JRuby 1.6 will ship with 1.9's singleton.rb for 1.8 mode, since it seems like the best option for fixing...
headius (Charles Nutter)

01/06/2011

10:05 PM Feature #4148: Time#strftime with %T broken on Windows
=begin
The document clearly shows the supported specifiers of Time#strftime.
See it's rdoc.

So, this is not b...
usa (Usaku NAKAMURA)
09:47 PM Feature #4148: Time#strftime with %T broken on Windows
=begin
The same thing seems to happen if the format string *includes* %P (only the uppercase P). Ruby -v output:
ru...
RvdBerg (René van den Berg)
06:32 PM Feature #4239 (Closed): Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8?
=begin
###########################
# This issue is translated from #4207.
# For Japanese: This translation need...
sorah (Sorah Fukumori)
03:13 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
(2011/01/06 7:24), Masatoshi SEKI wrote:
> 自分でrubyをビルドできるくらいのゆるいユーザーです。
>
> まだ1.9に移行できてないシステムをいくつかもっていいます...
shyouhei (Shyouhei Urabe)
08:19 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
横槍ですがsora_hといいます。


2011/1/6 Masatoshi SEKI <m_seki@mva.biglobe.ne.jp>:
> 1.8.8を出さない、ということとメンテナンスされなくなる、は...
sorah (Sorah Fukumori)
10:30 AM Revision 30479: * ext/socket/{getaddrinfo,getnameinfo}.c: include winsock2.h only when
specified to use winsock2 by user.
this problem is reported by kosaki.
usa (Usaku NAKAMURA)
09:13 AM Revision 30478: * win32/README.win32: fix the misunderstanding of previous commit.
usa (Usaku NAKAMURA)
09:04 AM Revision 30477: * 2011-01-06
svn
09:04 AM Revision 30476: * win32/README.win32: Add byacc and sed to required commands list.
It's documentaion bug. kosaki (Motohiro KOSAKI)
08:52 AM Bug #3416: [patch] ruby_1_8_7 [BUG] gc_sweep(): unknown data type 0x0
=begin
This bug was introduced in p226 with http://redmine.ruby-lang.org/repositories/revision/5?rev=26076, and fixe...
tmm1 (Aman Gupta)

01/05/2011

11:27 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
そういうわけで俺の側の事情を削ってもうちょっと整理すると、 1.8.8 に関して現状と問題点が以下のようになっており、

* なんだかんだで 1.9 が出てからだらだらと 3 年もたってしまった。この間、 1....
shyouhei (Shyouhei Urabe)
01:29 PM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
# 繰り言です。

Ruby の不幸の一つはユーザーと開発者が乖離していることかなと思います。
今、私も個人的には 1.8.7 は全然使っておりません。 1.8.7 までに関して
は、まあ一度乗りかかった船とい...
shyouhei (Shyouhei Urabe)
10:45 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
こんにちは、なかむら(う)です。

In message "[ruby-dev:42939] Re: [Ruby 1.8-Feature#4207][Open] これから「1.8.8」の話をしよう -- 1.8...
usa (Usaku NAKAMURA)
09:54 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
むらたです。

2010年12月26日10:12 Shyouhei Urabe <redmine@ruby-lang.org>:

> というわけで今すぐ出せとは言いませんから1.8の今後の方向性を決めま
>...
mrkn (Kenta Murata)
09:54 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
むらたです。

2011年1月4日22:17 Kenta Murata <muraken@gmail.com>:
> 2010年12月26日10:12 Shyouhei Urabe <redmine@ruby-l...
mrkn (Kenta Murata)
09:53 AM Feature #4207: これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
2011/1/5 Kenta Murata <muraken@gmail.com>:
>> 1週間以上経過して一つも意見が出ていない現状から、
>> 私は日本では誰も 1.8.8 を必要としていないのだと考えます。...
nahi (Hiroshi Nakamura)
10:09 AM Revision 30458: * 2011-01-05
svn
10:09 AM Revision 30457: * ext/socket/socket.c (make_addrinfo): skip IPv6 addresses when ruby
doesn't support IPv6 but system supports it.
[ruby-dev:42944] (#4230)
usa (Usaku NAKAMURA)

01/01/2011

01:59 AM Revision 30443: * intern.h (VALUE rb_ary_join): I have never seen this function
anywhere. nobu (Nobuyoshi Nakada)

12/31/2010

03:50 PM Bug #4229 (Open): Thread#raise 3rd form arguments ignored
=begin
It seems that at one point the Thread#raise method was documented to accept an array as the 3rd argument. As ...
djberg96 (Daniel Berger)

12/29/2010

04:14 AM Bug #4220 (Open): Non-descriptive error when failing to load compiled library
=begin
When loading nokogiri that was compile on a different architecture the error that is given simply states that...
harking (George M. Harkin)

12/27/2010

04:07 PM Backport #4206 (Closed): failed to set ext option for win32/configure.bat
=begin
This issue was solved with changeset r30401.
Akio, thank you for reporting this issue.
Your contribution to...
usa (Usaku NAKAMURA)
09:00 AM Backport #4206: failed to set ext option for win32/configure.bat
=begin
こんにちは、なかむら(う)です。

In message "[ruby-dev:42899] [Ruby 1.8-Bug#4206] failed to set ext option for win32/confi...
usa (Usaku NAKAMURA)
09:17 AM Backport #4212 (Rejected): Option :ftp_active_mode on open-uri not merged with current distribution of ruby-1.8.7
=begin
Backports don't add new feature; they only fix bugs.
=end
naruse (Yui NARUSE)
07:00 AM Backport #4212 (Rejected): Option :ftp_active_mode on open-uri not merged with current distribution of ruby-1.8.7
=begin
Hello,

The option :ftp_active_mode on open-uri is not available in any release of ruby-1.8.x, which is a...
shingonoide (Rui Andrada)
06:57 AM Revision 30402: * 2010-12-27
svn
06:57 AM Revision 30401: * win32/README.win32: note to need NT based OS to build ruby.
* win32/{configure.bat,setup.mak}: backport current build method from
trunk. [ruby-dev:42893] (#4206)
usa (Usaku NAKAMURA)

12/26/2010

11:07 PM Backport #4206: failed to set ext option for win32/configure.bat
=begin
1.9.2では問題なくMakefile内にconfigure_argsで埋め込まれます。
いつ頃のことか覚えていないのですが、中田さんに直してもらった記憶があるので、1.8系にバックポートされていないということだと...
arton (Akio Tajima)
09:10 PM Backport #4206: failed to set ext option for win32/configure.bat
=begin
artonさんはコミッタなので、何も見ず試さずで聞きますけど、1.8固有ですかこれ?
=end
usa (Usaku NAKAMURA)
07:36 AM Backport #4206 (Closed): failed to set ext option for win32/configure.bat
=begin
win32/configure.bat に対して --enable-tcltk-stubsを与えると以下のエラーになります。
NMAKE : fatal error U1065: オプション '-' は無効です。
...
arton (Akio Tajima)
10:12 AM Feature #4207 (Closed): これから「1.8.8」の話をしよう -- 1.8がこの先生きのこるには
=begin
現状 ruby_1_8 が出せる状況ではないのは存じあげております。誰よりも。

しかし1.9.0がリリースされてちょうど3年経ちました。1.8.7のリリースか
らも2年半、来年6月くらいに3年目を迎えま...
shyouhei (Shyouhei Urabe)
 

Also available in: Atom