DevelopersMeetingSummary20140517Japan » History » Version 1

Version 1/3 - Next » - Current version
Terence Lee, 05/19/2014 10:45 PM


DevelopersMeetingSummary20140517Japan

Agenda DevelopersMeeting20140517Japan

Attendance

  • in person: sora_h, shyouhei, akr, naruse, ko1, hsbt, tarui
  • online: matz, n0kada

[Feature #9772] IO#statfs and File::Statfs

not accepted. A gem should be made first.

[Feature #9647] File::Stat#birthtime

accepted

[Feature #9816] 文字列内の数字を数値として比較するメソッド

This feature is about comparing characters as numbers, like for Gem versions. For instance, 11 > 9 #=> true

  • still need more discussion
  • a good name

date

going separate it into a bundled gem

[Feature #9513] Hide Rational internal (akr)

accepted

[Feature #9826] Enumerable#slice_between (akr)

Matz likes the idea, but it needs a better name. There is already Array#slice.

[Feature #9071] Enumerable#slice_after (akr)

accepted

[Feature #9770] Etc.uname (akr)

accepted

[Feature #9842] system configuration variables (sysconf(), confstr(), pathconf() and fpathconf()) (akr)

accepted

[Feature #9834] Float#{next_float,prev_float} (akr)

accepted

[Feature #9632] [offtopic] remove doxygen?

dropping support for doxygen

[Feature #9711] Remove test-unit and minitest from stdlib. Can I remove test-unit? /cc sora_h (hsbt)

continuing to discuss about bundling test libraries test-unit/minitest.

remove rubyforge url(hsbt)

accepted

give up callcc (tarui)

accepted: going to fade out callcc support

Hash#comprized? (hone02)

http://olivierlacan.com/posts/proposal-for-a-better-ruby-hash-include/

  • need a good name
  • unclear what the usecase is
  • continue to discuss on redmine

[ANN] chkbuildXXX.hsbt.org

Using Ruby Association's funds, 4 machines have been prepared for chkbuild. chkbuild is the Ruby CI platform powering http://rubyci.org. We also want something besides Intel like running ARM on top of QEMU.

Next Meetings

  • 6/18: discussing [Feature #9711]
  • 7/26: big features for 2.2