Bug #7771

method 'gets' crashed

Added by jy j over 1 year ago. Updated over 1 year ago.

[ruby-core:51806]
Status:Rejected
Priority:Normal
Assignee:-
Category:core
Target version:1.9.3
ruby -v:ruby 1.9.3p374 (2013-01-15 revision 38858) [i686-linux] Backport:

Description

method 'gets' crashed when pass arguments like "ruby test.rb hello"

example
#file test.rb only one method
gets

#end

type "ruby test.rb" and enter will work well
but "ruby test.rb hello" will crash
In my machine(ubuntu 32):

ruby test.rb hello
test.rb:1:in gets': No such file or directory - hello (Errno::ENOENT)
from test.rb:1:in
gets'
from test.rb:1:in `'

History

#1 Updated by Charlie Somerville over 1 year ago

  • Subject changed from method 'gets' crashed to method 'gets' crashed

=begin
This is by design, (({gets})) will read from (({ARGV})) by default. If you want to read from the standard input even if there is a command line argument, use:

$stdin.gets
=end

#2 Updated by Charlie Somerville over 1 year ago

  • Status changed from Open to Rejected

Also available in: Atom PDF