Bug #8314

Segmentation fault

Added by Silviu Rusu 12 months ago. Updated 12 months ago.

[ruby-core:54529]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux] Backport:1.9.3: UNKNOWN, 2.0.0: UNKNOWN

Description

Occasionally happens on Travis CI with 2.0.0p0

By occasionally i mean that same code sometimes works sometimes does not.

Full backtrace here - https://travis-ci.org/espresso/rear/jobs/6530839

Never happens on 1.9x

Running ActiveRecord tests ...
......................................................................................./home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:227: [BUG] Segmentation fault
ruby 2.0.0p0 (2013-02-24 revision 39474) [x8664-linux]
-- Control frame information -----------------------------------------------
c:0090 p:---- s:0428 e:000427 CFUNC :class
eval
c:0089 p:0114 s:0422 e:000421 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:227
c:0088 p:0023 s:0414 e:000410 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:208
c:0087 p:0011 s:0407 e:000406 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:143
c:0086 p:0034 s:0400 e:000399 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:77
c:0085 p:0067 s:0394 e:000393 LAMBDA /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-more/view/base.rb:136 [FINISH]
c:0084 p:0155 s:0386 E:001eb0 METHOD /home/travis/build/espresso/rear/lib/rear/crud/helpers.rb:119
c:0083 p:0011 s:0376 e:000375 METHOD /home/travis/build/espresso/rear/lib/rear/crud/helpers.rb:99
c:0082 p:0340 s:0372 e:000369 BLOCK /home/travis/build/espresso/rear/lib/rear/templates/pane/layout.slim:51 [FINISH]
c:0081 p:---- s:0363 e:000362 CFUNC :each
c:0080 p:0146 s:0360 e:000359 BLOCK /home/travis/build/espresso/rear/lib/rear/templates/pane/layout.slim:44 [FINISH]
c:0079 p:---- s:0355 e:000354 CFUNC :each
c:0078 p:0171 s:0352 e:000351 BLOCK /home/travis/build/espresso/rear/lib/rear/templates/pane/layout.slim:36 [FINISH]
c:0077 p:---- s:0348 e:000347 CFUNC :instanceeval
c:0076 p:0030 s:0345 e:000344 CLASS /home/travis/build/espresso/rear/lib/rear/templates/pane/layout.slim:-1
c:0075 p:0031 s:0341 e:000340 METHOD /home/travis/build/espresso/rear/lib/rear/templates/pane/layout.slim:-3 [FINISH]
c:0074 p:---- s:0337 e:000336 CFUNC :call
c:0073 p:0027 s:0333 e:000332 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:144
c:0072 p:0034 s:0326 e:000325 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:77
c:0071 p:0067 s:0320 e:000319 LAMBDA /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-more/view/base.rb:136 [FINISH]
c:0070 p:0018 s:0312 e:000311 METHOD /home/travis/build/espresso/rear/lib/rear/helpers.rb:76
c:0069 p:0009 s:0307 e:000306 BLOCK /home/travis/build/espresso/rear/lib/rear/crud/actions.rb:6
c:0068 p:0214 s:0305 E:001418 BLOCK /home/travis/build/espresso/rear/lib/rear/templates/layout.slim:78 [FINISH]
c:0067 p:---- s:0299 e:000298 CFUNC :instance
eval
c:0066 p:0030 s:0296 E:001398 CLASS /home/travis/build/espresso/rear/lib/rear/templates/layout.slim:-1
c:0065 p:0031 s:0292 e:000291 METHOD /home/travis/build/espresso/rear/lib/rear/templates/layout.slim:-3 [FINISH]
c:0064 p:---- s:0288 e:000287 CFUNC :call
c:0063 p:0027 s:0284 e:000283 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:144
c:0062 p:0034 s:0277 e:000276 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/tilt-1.3.7/lib/tilt/template.rb:77
c:0061 p:0126 s:0271 e:000270 LAMBDA /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-more/view/base.rb:145 [FINISH]
c:0060 p:0020 s:0262 e:000261 METHOD /home/travis/build/espresso/rear/lib/rear/helpers.rb:81
c:0059 p:0009 s:0256 E:001f58 METHOD /home/travis/build/espresso/rear/lib/rear/crud/actions.rb:6
c:0058 p:0013 s:0253 e:000252 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-core/instance/base.rb:120
c:0057 p:0067 s:0250 e:000249 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-core/instance/base.rb:99
c:0056 p:0117 s:0241 e:000240 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-core/instance/base.rb:81 [FINISH]
c:0055 p:---- s:0236 e:000235 CFUNC :catch
c:0054 p:0050 s:0232 e:000231 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-core/instance/base.rb:68
c:0053 p:0011 s:0227 e:000226 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rack-1.5.2/lib/rack/builder.rb:138
c:0052 p:0367 s:0223 e:000222 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-builder/base.rb:189 [FINISH]
c:0051 p:---- s:0212 e:000211 CFUNC :each
c:0050 p:0043 s:0209 e:000208 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-builder/base.rb:162
c:0049 p:0009 s:0203 e:000202 LAMBDA /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-builder/base.rb:147 [FINISH]
c:0048 p:---- s:0200 e:000199 CFUNC :call
c:0047 p:0011 s:0196 e:000195 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-builder/base.rb:269
c:0046 p:0011 s:0190 e:000189 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-builder/base.rb:141
c:0045 p:0011 s:0186 e:000185 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/e-0.4.5/lib/e-core/controller/mounter.rb:8
c:0044 p:0114 s:0182 e:000181 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/sonar-0.1.5/lib/sonar/session.rb:91
c:0043 p:0087 s:0173 e:000172 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/sonar-0.1.5/lib/sonar/session.rb:50
c:0042 p:0171 s:0164 e:000163 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/sonar-0.1.5/lib/sonar.rb:80
c:0041 p:0048 s:0156 e:000155 LAMBDA /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/sonar-0.1.5/lib/sonar.rb:46 [FINISH]
c:0040 p:0007 s:0152 e:000151 BLOCK /home/travis/build/espresso/rear/test/test_filters.rb:220 [FINISH]
c:0039 p:---- s:0149 e:000148 CFUNC :instance
exec
c:0038 p:0011 s:0145 e:000144 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/specular-0.2.1/lib/specular/spec.rb:55 [FINISH]
c:0037 p:---- s:0143 e:000142 CFUNC :catch
c:0036 p:0151 s:0139 e:000138 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/specular-0.2.1/lib/specular/spec.rb:54
c:0035 p:0068 s:0131 e:000130 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/specular-0.2.1/lib/specular.rb:83 [FINISH]
c:0034 p:---- s:0124 e:000123 CFUNC :each
c:0033 p:0071 s:0121 e:000120 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/specular-0.2.1/lib/specular.rb:74
c:0032 p:0088 s:0117 E:0009d0 METHOD /home/travis/build/espresso/rear/Rakefile:23
c:0031 p:0011 s:0111 e:000110 METHOD /home/travis/build/espresso/rear/Rakefile:30
c:0030 p:0007 s:0108 e:000107 BLOCK /home/travis/build/espresso/rear/Rakefile:46 [FINISH]
c:0029 p:---- s:0106 e:000105 CFUNC :fork
c:0028 p:0014 s:0103 e:000102 BLOCK /home/travis/build/espresso/rear/Rakefile:46 [FINISH]
c:0027 p:---- s:0099 e:000098 CFUNC :call
c:0026 p:0028 s:0094 e:000093 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:246 [FINISH]
c:0025 p:---- s:0091 e:000090 CFUNC :each
c:0024 p:0115 s:0088 e:000087 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:241
c:0023 p:0075 s:0084 e:000083 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:184
c:0022 p:0014 s:0082 e:000081 METHOD /home/travis/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/monitor.rb:211
c:0021 p:0025 s:0079 e:000078 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177
c:0020 p:0024 s:0072 e:000071 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:205 [FINISH]
c:0019 p:---- s:0068 e:000067 CFUNC :each
c:0018 p:0031 s:0065 e:000064 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:203
c:0017 p:0062 s:0060 e:000059 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:183
c:0016 p:0014 s:0058 e:000057 METHOD /home/travis/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/monitor.rb:211
c:0015 p:0025 s:0055 e:000054 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:177
c:0014 p:0036 s:0048 e:000047 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/task.rb:170
c:0013 p:0033 s:0043 e:000042 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:143
c:0012 p:0009 s:0036 e:000035 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101 [FINISH]
c:0011 p:---- s:0033 e:000032 CFUNC :each
c:0010 p:0039 s:0030 e:000029 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:101
c:0009 p:0025 s:0028 e:000027 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:110
c:0008 p:0007 s:0024 e:000023 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:95
c:0007 p:0019 s:0021 e:000020 BLOCK /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:73
c:0006 p:0008 s:0019 e:000018 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:160
c:0005 p:0007 s:0015 e:000014 METHOD /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/lib/rake/application.rb:70
c:0004 p:0040 s:0012 e:000011 TOP /home/travis/.rvm/gems/ruby-2.0.0-p0/gems/rake-10.0.4/bin/rake:33 [FINISH]
c:0003 p:---- s:0010 e:000009 CFUNC :load
c:0002 p:0118 s:0006 E:000008 EVAL /home/travis/.rvm/gems/ruby-2.0.0-p0/bin/rake:23 [FINISH]
c:0001 p:0000 s:0002 E:0004c8 TOP [FINISH]

History

#1 Updated by Charlie Somerville 12 months ago

  • Status changed from Open to Closed

Duplicate of #8100. This will be fixed in the next patchlevel of 2.0.0

#2 Updated by Silviu Rusu 12 months ago

Thank you

Also available in: Atom PDF