General

Profile

eviljoel (evil joel)

  • Login: eviljoel
  • Registered on: 07/24/2018
  • Last connection: 04/30/2023

Issues

open closed Total
Assigned issues 0 0 0
Reported issues 0 3 3

Like

Activity

04/07/2023

11:35 PM Ruby master Bug #19585 (Closed): Ruby Fails to Build on macOS with --enable-shared and --with-jemalloc
Ruby fails to build on macOS 12.6.4 when configured with --enable-shared and --with-jemalloc. I receive the following... eviljoel (evil joel)

04/05/2023

05:41 PM Ruby master Bug #19161: Cannot compile 3.0.5 or 3.1.3 on Red Hat Enterprise Linux 7
@nobu, attached are the requested files. I also included files for Ruby 3.1.4 and 3.0.6. All three versions reported ... eviljoel (evil joel)
01:43 AM Ruby master Bug #19161: Cannot compile 3.0.5 or 3.1.3 on Red Hat Enterprise Linux 7
@hsbt, @nagachika, and @nobu, despite the release notes, this was not successfully backported to Ruby 3.2 in Ruby 3.2... eviljoel (evil joel)

03/09/2023

05:00 PM Ruby master Bug #19518: Recent Source Releases Do Not Compile on CentOS 7 Due to configure Script Error Generated By autoconf >= 2.70
Agreed that this is a duplicate.
Thanks @jaruga. I forgot about SCL. I should probably look into integrating that ...
eviljoel (evil joel)

03/08/2023

07:23 PM Ruby master Bug #19518: Recent Source Releases Do Not Compile on CentOS 7 Due to configure Script Error Generated By autoconf >= 2.70
I listed the wrong compiler flags above. The correct flags are -std=gnu11 and -std=gnu99. eviljoel (evil joel)
07:14 PM Ruby master Bug #19518: Recent Source Releases Do Not Compile on CentOS 7 Due to configure Script Error Generated By autoconf >= 2.70
Forgot to include the compile error:
```
compiling miniinit.c
In file included from vm_core.h:164:0,
...
eviljoel (evil joel)
07:09 PM Ruby master Bug #19518 (Closed): Recent Source Releases Do Not Compile on CentOS 7 Due to configure Script Error Generated By autoconf >= 2.70
Source releases where the 'configure' script was generated by autoconf 2.70 or greater results in a failed Ruby compi... eviljoel (evil joel)

01/31/2023

11:04 PM Ruby master Bug #17664: Behavior of sockets changed in Ruby 3.0 to non-blocking
I can't use IO.wait_readable and IO.wait_writable because OpenSSL can renegotiate with two-way communication at any t... eviljoel (evil joel)
08:14 PM Ruby master Bug #17664: Behavior of sockets changed in Ruby 3.0 to non-blocking
@ioquatix, thank you for your reply.
The sockets are created in Ruby. I'm interacting with OpenSSL via FFI, so tha...
eviljoel (evil joel)

01/30/2023

11:28 PM Ruby master Bug #17664: Behavior of sockets changed in Ruby 3.0 to non-blocking
@ioquatix, I maintain a proprietary, custom OpenSSL C extension as part of my company's security scanner. This change... eviljoel (evil joel)

Also available in: Atom