sawa (Tsuyoshi Sawada)
- Registered on: 04/27/2011
- Last connection: 06/05/2018
- 07:28 AM Ruby trunk Feature #14951: New operator to evaluate truthy/falsy/logical equivalence
- I propose to extend the exclusive or operator `^` to be defined on `Object`. For `Integer`, the method would be overw...
- 09:00 AM Ruby trunk Feature #14913: Extend case to match several values at once
- Perhaps, you can redefine `Array#===` and use arrays in the following way:
case [x, y]
when [0..10, 0..1...
- 08:59 AM Ruby trunk Feature #14781: Enumerator#generate
- I propose the following:
- 06:02 AM Ruby trunk Bug #14823: Endless Range Excluding End
- I agree with shevegen. In case one of the two is to be removed, it is `1..` that should be removed, not the other way...
- 07:35 AM Ruby trunk Feature #14788: `Hash#keys` Could Accept a Block
- If I were you, I would rather request a new method named `Hash#select_keys` for that purpose.
- 04:39 AM Ruby trunk Feature #14763: Allow more Enumerable methods to accept method names as symbol arguments
- I think `reduce` or `inject` taking a method name as an argument was convenient in the old days when symbol to proc w...
- 07:32 AM Ruby trunk Feature #14594: Rethink yield_self's name
- I disagree with the names proposed, but I agree that the current name is too long.
Here are yet other name candida...
- 07:23 AM Ruby trunk Feature #14594: Rethink yield_self's name
- `map` is one of the worst names for this feature in my opinion. Generalizaing from cmoel's proposal to use `map` for ...
- 12:14 PM Ruby trunk Feature #14022: String#surround
- I admit that now we can use `yield_self`. I didn't think interpolation was elegant enough, but I think I can live wit...
- 04:45 AM Ruby trunk Feature #14580: Hash#store accepts a block
- Why not write `hash[:a]+= 42`?
Also available in: Atom