mrkn (Kenta Murata)





02:41 AM Ruby trunk Misc #15782: DevelopersMeeting20190522Japan
Today's venue has been changed to Speee Inc. at Roppongi.
Do not go pixiv.
mrkn (Kenta Murata)


03:49 AM Ruby trunk Feature #15837 (Open): Module#name_components
I sometimes wrote the expression like below to extract the components of class path:
mrkn (Kenta Murata)


03:34 AM Ruby trunk Revision f1fb989f (git): enumerator.c: make arith_seq_first support nil begin
* enumerator.c: (arith_seq_first): support nil begin.
* test/ruby/test_arithmetic_sequence.rb (test_first): add asse...
mrkn (Kenta Murata)
03:34 AM Ruby trunk Revision 53d3fe06 (git): ruby/test_arithmetic_sequence.rb: add assertions for beginless and endless ranges
git-svn-id: svn+ssh:// b2dd03c8-39d4-4d8f-98ff-823fe69b080e mrkn (Kenta Murata)
03:34 AM Ruby trunk Revision dcb37d06 (git): range.c: support to make beginless arithmetic sequences
* range.c (range_step): fix the guard condition so that a beginless
range can be turned into a beginless arithmetic...
mrkn (Kenta Murata)


06:25 AM Ruby trunk Feature #15653: Proposal: Add Time#floor
ActiveRecord を使うアプリケーションで、時刻をDBに入れて取り出すと秒の単位で切り捨てられます。
昔 Rails アプリケーションを作っていた頃は、この挙動のためにテストコードでの時刻の比較が面倒だったことを思い出しました。
mrkn (Kenta Murata)


03:29 PM Ruby trunk Revision 75708642 (git): Introduce RVALUE_EMBED_LEN_MAX to remove a magic number
* include/ruby/ruby.h: replace a magic number with RVALUE_EMBED_LEN_MAX,
which indicates the number of VALUE elemen...
mrkn (Kenta Murata)


06:12 AM Ruby trunk Feature #15573: Permit zero step in Numeric#step and Range#step
> Tell us why? Consistency?
The reason is that zero step allows when the block is not given.
>> 1.step(10,...
mrkn (Kenta Murata)


06:16 AM Ruby trunk Bug #15518: good old Infinite range notation behavior
I fixed the case for ranges whose end is Float::INFINITY.
If you want to continue to discuss for the other cases, pl...
mrkn (Kenta Murata)
06:06 AM Ruby trunk Bug #15518 (Closed): good old Infinite range notation behavior
Applied in changeset trunk|r66947.
enumerator.c: fix arith_seq_first for Infinity
* enumerator.c (arith_...
mrkn (Kenta Murata)

Also available in: Atom