General

Profile

thomthom (Thomas Thomassen)

  • Login: thomthom
  • Email: thomas@thomthom.net
  • Registered on: 08/08/2012
  • Last connection: 11/07/2022

Issues

open closed Total
Assigned issues 0 0 0
Reported issues 1 5 6

Like

Activity

01/04/2023

01:17 PM Ruby master Bug #19115: RubyGems fails to detect OpenSSL in --with-static-linked-ext builds
I built Ruby 3.1.2 that we use in our product with this patch applied, and it worked on our systems. Would be nice to... thomthom (Thomas Thomassen)

12/20/2022

10:34 AM Ruby master Bug #19246: Rebuilding the loaded feature index much slower in Ruby 3.1
One more thing (Sorry for sounding like Colombo), we also remove items from `$LOADED_FEATURES` when plugins are updat... thomthom (Thomas Thomassen)
10:19 AM Ruby master Bug #19246: Rebuilding the loaded feature index much slower in Ruby 3.1
Additional note: For development purposes there are also need to remove from `$LOADED_FEATURES` in order to reload fi... thomthom (Thomas Thomassen)
10:12 AM Ruby master Bug #19246 (Open): Rebuilding the loaded feature index much slower in Ruby 3.1
Some background to this issue: (This is a case that is unconventional usage of Ruby, but I hope you bear with me.)
...
thomthom (Thomas Thomassen)

12/05/2022

02:16 PM Ruby master Bug #19115: RubyGems fails to detect OpenSSL in --with-static-linked-ext builds
Will this patch be pack-ported to the 3.1 branch? thomthom (Thomas Thomassen)

11/16/2022

01:25 PM Ruby master Bug #19115: RubyGems fails to detect OpenSSL in --with-static-linked-ext builds
So, this isn't necessarily limited to macOS? It just happens to be the configuration we're using on that platform? thomthom (Thomas Thomassen)

11/11/2022

03:32 PM Ruby master Bug #18599: `vm->loaded_features_snapshot` became very inefficient in Ruby 3.1
Is this targeted to be ported to Ruby 3.1? I see it's not included in 3.1.2 nor in the ruby_3_1 branch. thomthom (Thomas Thomassen)

11/10/2022

12:02 PM Ruby master Bug #19115: RubyGems fails to detect OpenSSL in --with-static-linked-ext builds
After looking into this closer, `autoload` has been broken with this config at least back to Ruby 2.5 (Did test anyth... thomthom (Thomas Thomassen)

11/09/2022

01:16 PM Ruby master Bug #18876: OpenSSL fails to autoload in --with-static-linked-ext builds
alanwu (Alan Wu) wrote in #note-17:
> thomthom (Thomas Thomassen) wrote in #note-16:
> > Should I be making a new t...
thomthom (Thomas Thomassen)
01:15 PM Ruby master Bug #19115 (Closed): RubyGems fails to detect OpenSSL in --with-static-linked-ext builds
Related discussion: https://bugs.ruby-lang.org/issues/18876
We are seeing OpenSSL failing to autoload with the Rub...
thomthom (Thomas Thomassen)

Also available in: Atom