Project

General

Profile

Bug #17629 » Dockerfile

radarek (Radosław Bułat), 02/14/2021 02:53 PM

 
1
FROM ubuntu:focal
2

    
3
RUN apt-get update -qq && \
4
  apt-get install -y \
5
  autoconf \
6
  build-essential \
7
  git \
8
  libedit-dev \
9
  wget
10

    
11
WORKDIR /app
12

    
13
RUN wget https://cache.ruby-lang.org/pub/ruby/3.0/ruby-3.0.0.tar.gz && \
14
  tar xfz ruby-3.0.0.tar.gz && \
15
  cd ruby-3.0.0 && \
16
  autoconf && \
17
  ./configure --prefix=/opt && \
18
  make install