Project

General

Profile

Feature #10083

String.to_i unexpected behavior

Added by joseph castro over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
ruby-core
[ruby-core:63943]

Description

Hi

There's the issue:

"String".to_i  => 0  

This must be NIL or at least error, but no 0, because the string is not a number, also:

"10String".to_i => 10 

Is not 10, because "10String" is not a number, maybe is necessary a new method to get a number from any string, because to_i is to convert into a Integer and that should return an error.

Greetings everyone

History

#1 [ruby-core:63950] Updated by Nobuyoshi Nakada over 1 year ago

  • Description updated (diff)
  • Status changed from Open to Rejected

You can use Integer("String") instead.

Also available in: Atom PDF