Project

General

Profile

Actions

Bug #10596

closed

gem install ssl failure

Added by robyn294 (Robyn Cantrell) over 7 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.5p273 (2014-11-13 revision 48405) [i386-mingw32]
[ruby-core:66831]

Description

When trying to install a gem, whether using gem install or through gemfile, I get the following error :

ERROR: Could not find a valid gem 'bcrypt' (>= 0), here is why:
Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certifi
cate B: certificate verify failed (https://rubygems.org/latest_specs.4.8.gz)


Related issues 1 (0 open1 closed)

Related to Ruby master - Bug #10627: gem update fails with a certificate verification errorRejected12/21/2014Actions

Updated by luislavena (Luis Lavena) over 7 years ago

  • Status changed from Open to Rejected

This is caused by changes on SSL certificates used by rubygems.org.

Please read the following:

https://gist.github.com/luislavena/f064211759ee0f806c88

This is also covered in RubyInstaller's group, as sticky note and mentioned several times on RubyGems issue tracker on GitHub.

Updated by luislavena (Luis Lavena) over 7 years ago

  • Related to Bug #10627: gem update fails with a certificate verification error added
Actions

Also available in: Atom PDF