Project

General

Profile

Actions

Bug #11112

closed

Segfault on `require json` in Ruby 2.1.6

Added by nathanmlong (Nathan Long) about 7 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.6p336 (2015-04-13 revision 50298) [x86_64-darwin13.0]
[ruby-core:69051]

Description

I've just installed Ruby 2.1.6 using ruby-install. If I start irb and type require "json", I get a segfault. I'm on OSX. I've also installed and tried this on Ruby 2.1.2-2.1.5, and 2.1.6 is the only version that segfaults.

I'm attaching the console output and the crash report from ~/Library/Logs/DiagnosticReports/ruby_2015-05-01-100546_natecomp.crash

I'd be happy to answer further questions or try things that may help in diagnosing this.


Files

crash_console_output.txt (10.1 KB) crash_console_output.txt console output from "require 'json'" in irb nathanmlong (Nathan Long), 05/01/2015 02:07 PM
ruby_2015-05-01-100546_natecomp.crash (15.5 KB) ruby_2015-05-01-100546_natecomp.crash diagnostic report nathanmlong (Nathan Long), 05/01/2015 02:07 PM

Updated by usa (Usaku NAKAMURA) about 7 years ago

  • Status changed from Open to Rejected

Your json extension is linked to ruby 2.0.0, not ruby 2.1.6.

9   libruby.2.0.0.dylib           	0x0000000100f1c2ab rb_require + 11
10  parser.bundle                 	0x0000000100ee28bf Init_parser + 19 (parser.rl:893)
11  ruby                          	0x00000001009e6e32 dln_load + 226 (dln.c:1359)

Actions

Also available in: Atom PDF