Project

General

Profile

Bug #11238

Cannot install any gem since upgrading to Yosemite: Segmentation fault in openssl.bundle

Added by carolineschnapp (Caroline Schnapp) over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:69496]

Description

gem install bundler

/usr/local/lib/ruby/2.2.0/x86_64-darwin12.0/openssl.bundle: [BUG] Segmentation fault at 0x00000000000440

Files

bug-11238.log (10 KB) bug-11238.log nobu (Nobuyoshi Nakada), 06/09/2015 07:43 AM

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

2   ruby                                0x000000010a9400bf sigsegv + 143
3   libsystem_platform.dylib            0x00007fff8d2c5f1a _sigtramp + 26
4   libruby.2.2.0.dylib                 0x000000010adc0242 ruby_xmalloc + 17

You seem to load an extension library linked against the shared library from statically linked ruby.

Also available in: Atom PDF