Project

General

Profile

Bug #11557

Capturing Limits

Added by ronald.petty (Ronald Petty) about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:<unknown>]

Description

Ruby 2.2

In IRB and via normal ruby file.rb, you can create unexpected behavior via capture groups.

Via IRB

"asdf".match(/(.)/)
$1
 => "a" 
$2000000
 => nil 
$2000000000000000
RangeError: integer 2467954688 too big to convert to `int'
$999999999999999999999999999999999999
 => "a" 

Via ruby

ruby a.rb (
"a"
ruby a.rb 
a.rb: integer 2467954690 too big to convert to `int' (RangeError)
ruby a.rb 
"a"

Related issues

Is duplicate of Ruby master - Bug #11192: capture group special variable with large index invokes UBClosedActions

History

#1

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Is duplicate of Bug #11192: capture group special variable with large index invokes UB added
#2

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Description updated (diff)
  • Status changed from Open to Closed

Also available in: Atom PDF