Project

General

Profile

Bug #12014

Visual Studio 2015 build error __imp___pioinfo

Added by nbush (Nathan Bush) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
git ruby_2_3 & trunk
Backport:
[ruby-core:73260]

Description

#11118 still applies for ruby_2_2 on git. This is ruby_2_3 and trunk, revision ed2e608.

I've been following the suggestions of https://github.com/nurse/ruby/blob/msvc14/appveyor.yml aside from version updates, and added gnuwin32 binaries to PATH.

Running nmake fails with:

user32.lib advapi32.lib shell32.lib ws2_32.lib iphlpapi.lib imagehlp.lib shlwapi.lib
linking miniruby.exe
win32.obj : error LNK2001: unresolved external symbol __imp___pioinfo
miniruby.exe : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\amd64\cl.EXE"' : return code '0x2'
Stop.

Related issues

Is duplicate of Ruby master - Bug #11118: Unable to build Ruby with Visual Studio 2015 RCClosedActions

Associated revisions

Revision 9afc312b
Added by naruse (Yui NARUSE) over 3 years ago

Support MSVC14 and 15 [Bug #11118]

Search _pioinfo which is not exported after MSVC14.
[Bug #12014] [GH-884]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@54737 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54737
Added by naruse (Yui NARUSE) over 3 years ago

Support MSVC14 and 15 [Bug #11118]

Search _pioinfo which is not exported after MSVC14.
[Bug #12014] [GH-884]

Revision 54737
Added by naruse (Yui NARUSE) over 3 years ago

Support MSVC14 and 15 [Bug #11118]

Search _pioinfo which is not exported after MSVC14.
[Bug #12014] [GH-884]

Revision 54737
Added by naruse (Yui NARUSE) over 3 years ago

Support MSVC14 and 15 [Bug #11118]

Search _pioinfo which is not exported after MSVC14.
[Bug #12014] [GH-884]

Revision 54737
Added by naruse (Yui NARUSE) over 3 years ago

Support MSVC14 and 15 [Bug #11118]

Search _pioinfo which is not exported after MSVC14.
[Bug #12014] [GH-884]

Revision 85ddcb93
Added by usa (Usaku NAKAMURA) over 1 year ago

merge revision(s) 54737,54740,55792: [Backport #14623]

    Support MSVC14 and 15 [Bug #11118]

    Search _pioinfo which is not exported after MSVC14.
    [Bug #12014] [GH-884]

    win32.c: suppress warnings

    * win32/win32.c (set_pioinfo_extra): remove "/*" within comment.
    * win32/win32.c (set_pioinfo_extra): use more reliable way to search
      the position of pioinfo of VC14, and also support debug library of it.
      patched by davispuh AT gmail.com
      [ruby-core:76644] [Bug #12644]
      this fixes also [Bug #12631]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@62884 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 62884
Added by usa (Usaku NAKAMURA) over 1 year ago

merge revision(s) 54737,54740,55792: [Backport #14623]

Support MSVC14 and 15 [Bug #11118]

Search _pioinfo which is not exported after MSVC14.
[Bug #12014] [GH-884]

win32.c: suppress warnings

* win32/win32.c (set_pioinfo_extra): remove "/*" within comment.
* win32/win32.c (set_pioinfo_extra): use more reliable way to search
  the position of pioinfo of VC14, and also support debug library of it.
  patched by davispuh AT gmail.com
  [ruby-core:76644] [Bug #12644]
  this fixes also [Bug #12631]

History

Updated by nbush (Nathan Bush) over 3 years ago

  • Description updated (diff)
#2

Updated by naruse (Yui NARUSE) over 3 years ago

  • Related to Bug #11118: Unable to build Ruby with Visual Studio 2015 RC added

Updated by naruse (Yui NARUSE) over 3 years ago

  • Status changed from Open to Closed

Ruby 2.2 and 2.3 doesn't and won't support Visual Studio 2015.
Use 2013 or prior, or mingw64.

Anyway this ticket is considered duplicated with #11118 as you say.

#4

Updated by naruse (Yui NARUSE) over 3 years ago

  • Related to deleted (Bug #11118: Unable to build Ruby with Visual Studio 2015 RC)
#5

Updated by naruse (Yui NARUSE) over 3 years ago

  • Is duplicate of Bug #11118: Unable to build Ruby with Visual Studio 2015 RC added

Updated by naruse (Yui NARUSE) over 3 years ago

  • Backport changed from 2.3: UNKNOWN to 2.3: WONTFIX

Also available in: Atom PDF