Project

General

Profile

Bug #124

Module#remove_method broken in 1.8.6-p166

Added by NoKarma (Arthur Schreiber) almost 12 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
[ruby-core:17154]

Description

=begin
Module#remove Method should raise a NameError when trying to remove non-existant methods.

On Ruby 1.8.6-p111, Ruby 1.8.6-p114, Ruby 1.8.7, Ruby 1.8.7-p7 and Ruby 1.8.7-p17:

irb(main):001:0> class A; remove_method :blabla; end
NameError: method blabla' not defined in A
from (irb):1:in
remove_method'
from (irb):1

But on Ruby 1.8.6-p166:

irb(main):001:0> class A; remove_method :blabla; end
=> A
=end

#1

Updated by vvs (Vladimir Sizikov) almost 12 years ago

=begin
Looks like r16816:
"merge revision(s) 13586:

  • eval.c (remove_method): should not remove undef place holder. [ruby-dev:31817]"

is the reason for this regression.
=end

#2

Updated by Anonymous almost 12 years ago

=begin
Issue #124 has been updated by Vladimir Sizikov.

Looks like r16816:
"merge revision(s) 13586:

  • eval.c (remove_method): should not remove undef place holder. [ruby-dev:31817]"

is the reason for this regression.


Bug #124: Module#remove_method broken in 1.8.6-p166
http://redmine.ruby-lang.org/issues/show/124

Author: Arthur Schreiber
Status: Open
Priority: Normal
Assigned to:
Category:
Target version:

Module#remove Method should raise a NameError when trying to remove non-existant methods.

On Ruby 1.8.6-p111, Ruby 1.8.6-p114, Ruby 1.8.7, Ruby 1.8.7-p7 and Ruby 1.8.7-p17:

irb(main):001:0> class A; remove_method :blabla; end
NameError: method blabla' not defined in A
from (irb):1:in
remove_method'
from (irb):1

But on Ruby 1.8.6-p166:

irb(main):001:0> class A; remove_method :blabla; end
=> A


You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://redmine.ruby-lang.org/my/account

=end

#3

Updated by nobu (Nobuyoshi Nakada) over 11 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
Merged to 1.8.6 branch in the repository, at r17646.
=end

Also available in: Atom PDF