Project

General

Profile

Bug #12727

Segfault when subclassing Thread with bad initialize

Added by sandal (Gregory Brown) over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:77157]

Description

I imagine that this is a really unlikely problem to encounter in real code, but...

class MyThing < Thread
  def initialize
    raise
  end
end

MyThing.new do
  loop do
    puts "hello"
    sleep(1)
  end
end

sleep

Produces a segfault for me, and I've had someone else confirm as well.


Related issues

Is duplicate of Ruby trunk - Bug #11959: Segfault during `exit' in thread initialize (Extended class).ClosedActions

History

Updated by sandal (Gregory Brown) over 2 years ago

  • Subject changed from Segfault when subclassing Thread to Segfault when subclassing Thread with bad initialize
#2

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Is duplicate of Bug #11959: Segfault during `exit' in thread initialize (Extended class). added

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

  • Status changed from Open to Rejected

Also available in: Atom PDF