Project

General

Profile

Bug #12917

Segfault in list_ids_bsearch

Added by duncan_bayne (Duncan Bayne) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux]
[ruby-core:78070]

Description

Intermittently (maybe every five builds or so?) my CI build is causing Ruby to crash.

I have rebuilt Ruby and debugging symbols from source, with no optimisations, in order to take a look with GDB. The problem persists with this build, as well as one with optimisations on and symbols off.

#0  0x00007f0353a105f7 in raise () from /lib64/libc.so.6
#1  0x00007f0353a11ce8 in abort () from /lib64/libc.so.6
#2  0x00005634b80e3766 in die () at error.c:407
#3  0x00005634b80e39b7 in rb_bug_context (ctx=0x5634b8fa1a00, fmt=0x5634b811b08f "Segmentation fault at %p") at error.c:437
#4  0x00005634b7ff25bf in sigsegv (sig=11, info=0x5634b8fa1b30, ctx=0x5634b8fa1a00) at signal.c:890
#5  <signal handler called>
#6  0x00005634b802082e in list_ids_bsearch (keys=0x21, key=189, num=33) at id_table.c:567
...
(gdb) frame 6
#6  0x00005634b802082e in list_ids_bsearch (keys=0x21, key=189, num=33) at id_table.c:567
567         id_key_t kp = keys[p];
(gdb) list
562
563     if (min >= max) {
564         break;
565     }
566     else {
567         id_key_t kp = keys[p];
568         assert(p < max);
569         assert(p >= min);
570
571         if      (kp > key) max = p;

I've attached the full control frame information produced during one of the failing CI builds.


Files

segfault.log (671 KB) segfault.log duncan_bayne (Duncan Bayne), 11/10/2016 05:10 AM

Related issues

Is duplicate of Ruby master - Bug #12614: Segmentation Fault on Ruby 2.3.1ClosedActions

Updated by wanabe (_ wanabe) over 3 years ago

It might be same issue as #12614.
Would you try latest trunk or ruby_2_3 branch, or re-compiling your ruby-2.3.1 with r56019?

#2

Updated by wanabe (_ wanabe) over 3 years ago

  • Related to Bug #12614: Segmentation Fault on Ruby 2.3.1 added

Updated by duncan_bayne (Duncan Bayne) over 3 years ago

I applied changeset r55896 to our Ruby build, and CI now experiences no segfaults. I guess it was the same bug :) Please feel free to close this as a duplicate, and thanks very much for the suggestion :)

Updated by wanabe (_ wanabe) over 3 years ago

  • Status changed from Open to Closed
#5

Updated by wanabe (_ wanabe) over 3 years ago

  • Related to deleted (Bug #12614: Segmentation Fault on Ruby 2.3.1)
#6

Updated by wanabe (_ wanabe) over 3 years ago

  • Is duplicate of Bug #12614: Segmentation Fault on Ruby 2.3.1 added

Also available in: Atom PDF