Project

General

Profile

Bug #13121

Backport r57108 (fix memory corruption by width underflow)

Added by nagachika (Tomoyuki Chikanaga) over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:79043]

Related issues

Is duplicate of Ruby trunk - Bug #13049: Backport r57108 (sprintf.c: fix width underflow)Closed

Associated revisions

Revision 2e4b5a32
Added by nagachika (Tomoyuki Chikanaga) over 1 year ago

merge revision(s) 57108: [Backport #13121]

sprintf.c: fix width underflow

* sprintf.c (rb_str_format): fix memory corruption by width

underflow. https://github.com/mruby/mruby/issues/3347

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@57340 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 57340
Added by nagachika (Tomoyuki Chikanaga) over 1 year ago

merge revision(s) 57108: [Backport #13121]

sprintf.c: fix width underflow

* sprintf.c (rb_str_format): fix memory corruption by width

underflow. https://github.com/mruby/mruby/issues/3347

History

#1 [ruby-core:79089] Updated by nagachika (Tomoyuki Chikanaga) over 1 year ago

  • Backport changed from 2.2: UNKNOWN, 2.3: REQUIRED, 2.4: REQUIRED to 2.2: REQUIRED, 2.3: REQUIRED, 2.4: DONTNEED

#2 [ruby-core:79090] Updated by nagachika (Tomoyuki Chikanaga) over 1 year ago

  • Backport changed from 2.2: REQUIRED, 2.3: REQUIRED, 2.4: DONTNEED to 2.2: REQUIRED, 2.3: DONE, 2.4: DONTNEED

ruby_2_3 r57340 merged revision(s) 57108.

#3 [ruby-core:79091] Updated by nagachika (Tomoyuki Chikanaga) over 1 year ago

  • Backport changed from 2.2: REQUIRED, 2.3: DONE, 2.4: DONTNEED to 2.2: DONE, 2.3: DONE, 2.4: DONTNEED

#4 Updated by nagachika (Tomoyuki Chikanaga) over 1 year ago

  • Is duplicate of Bug #13049: Backport r57108 (sprintf.c: fix width underflow) added

Also available in: Atom PDF