Project

General

Profile

Bug #13139

bug in the Ruby interpreter or extension for new AIX VM chef-client run.

Added by ibellinf (Ian Bellinfantie) almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.6p336 (2015-04-13 revision 50298) [powerpc-aix6.1.0.0]
[ruby-core:79167]

Description

installed the Chef-client on a new AIX VM.
Ran a bootstrap from windows SDK

PS C:\Users\Administrator\chef-repo> knife bootstrap xx.xx.xx.xx --ssh-user root
--run-list 'recipe[aix]'

and got this ... only listing the last couple of lines as most lost in the scroll.

1109 /opt/chef/embedded/lib/ruby/gems/2.1.0/gems/ohai-8.7.0/lib/oha
i/mixin/network_constants.rb
1110 /opt/chef/embedded/lib/ruby/gems/2.1.0/gems/ohai-8.7.0/lib/oha
i/mixin/softlayer_metadata.rb
1111 /opt/chef/embedded/lib/ruby/gems/2.1.0/gems/ohai-8.7.0/lib/oha
i/common/dmi.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension
libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

[2017-01-19T22:45:59-06:00] FATAL: Chef::Exceptions::ChildConvergeEr
ror: Chef run process terminated by signal 6 (LOST)
PS C:\Users\Administrator\chef-repo>

subsequent runs produce

==================================================================

Error Syncing Cookbooks:

==================================================================

Unexpected Error:


ThreadError: can't create Thread: Resource temporarily unavailable

I tried this possible fix
https://github.com/chef/chef/issues/2531

and rebooted...still got the ThreadError.

also still get the same Error Syncing Cookbooks: if I use chef-client on the VM

AIX VM oslevel -s
7100-04-03-1642

ruby on the desktop

PS C:\Users\Administrator\chef-repo> ruby -v
ruby 2.3.1p112 (2016-04-26 revision 54768) [i386-mingw32]

History

Updated by ibellinf (Ian Bellinfantie) almost 3 years ago

Sorry, same error is obtained even if I put the correct recipe specification...

Updated by ibellinf (Ian Bellinfantie) almost 3 years ago

This problem goes away either after waiting for a while and retrying... or by forcing the upload of the missing cookbooks from the client sync list again.
e.g. from the ChefDK..... knife upload cookbook --force

Updated by shyouhei (Shyouhei Urabe) almost 3 years ago

  • Status changed from Open to Closed

Good to hear the problem disappeared.

Updated by ibellinf (Ian Bellinfantie) almost 3 years ago

Actually, to confirm, the problem went away with the update for all three of these. The important change was for data= -1. Just doing rss and nofiles does not work.

chsec -f /etc/security/limits -s default -a "rss=-1"
chsec -f /etc/security/limits -s default -a "data=-1"
chsec -f /etc/security/limits -s default -a "nofiles=50000"

https://docs.chef.io/ctl_chef_client.html

Also available in: Atom PDF