Project

General

Profile

Actions

Bug #1334

closed

ruby-1.9.1-p0 cannot install libs to /usr/lib/ruby/1.9 anymore with --program-suffix

Added by rbrown (Richard Brown) about 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.1p0 (2009-01-30 revision 21907) [i686-linux]
Backport:
[ruby-core:23067]

Description

=begin
Changes to configure.in mean that ./configure --program-suffix=19 --ruby-version=minor makes rubylibdir /usr/lib/ruby19/1.9, in contrast to 1.8 where ./configure --program-suffix=18 would create /usr/lib/ruby/1.8.

I've attached three patches:

0001 adds a new configure switch --with-rubylibprefix that defaults to libdir/RUBY_INSTALL_NAME, sets rubylibdir to rubylibprefix/ruby_version and defaults sitedir and vendordir to rubylibprefix/{site_ruby,vendor_ruby}

0002 fixes the help strings for the three header dir switches

0003 Updates configure.in to use AS_HELP_STRING

I've included them all on this patch because 0003 depends on 0001 and 0002
=end


Files

Actions #1

Updated by yugui (Yuki Sonoda) almost 12 years ago

  • Status changed from Open to Closed

=begin

=end

Actions

Also available in: Atom PDF