Project

General

Profile

Bug #14154

Ruby 2.4 and support for rails 3

Added by lima (Rafael Lima) almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.4.2
[ruby-core:84088]

Description

After upgrading a Rails project from 2.1.5 to 2.4.2 I ran into a number of failing tests. Seems like a behavior of ActiveSupport::Duration can't be coerced into Integer

I’ve looked at some important changes that are part of the Ruby 2.4 (such as Integer class unification). These modifications represent improvements to the language, but at the same time, they may not be fully compatible with existing code that runs in Ruby 2.3 or earlier. Some extra work might be needed with gems or third-party libraries to avoid problems with Ruby 2.4.

Was it intended to be that way even though it's not a major upgrade?

History

Updated by yuki24 (Yuki Nishijima) almost 2 years ago

  • Status changed from Open to Closed

Thanks for your report. 2.4 is not fully compatible with older versions of Ruby, and that's intentional. Please refer to our maintenance policy https://bugs.ruby-lang.org/projects/ruby/wiki/GeneralMaintenancePolicy and the discussion around it: https://bugs.ruby-lang.org/issues/9215. I also don't believe Rails 3 has support for recent versions of Ruby such as 2.4. To learn more about practices on upgrading Rails, please refer to Rails' official upgrade guide: http://guides.rubyonrails.org/upgrading_ruby_on_rails.html

Also available in: Atom PDF