Project

General

Profile

Bug #14242

Fails to build ruby 2.5.0 on CentOS 6

Added by yasuhirokimura (Yasuhiro KIMURA) 11 months ago. Updated 11 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-linux]
[ruby-dev:50399]

Description

kimura@www10268uf[2018]% cat /etc/redhat-release
CentOS release 6.9 (Final)
kimura@www10268uf[2019]% gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC)
kimura@www10268uf[2020]% ./configure
(snip)
kimura@www10268uf[2023]% make
(snip)
make[1]: Leaving directory `/home/kimura/work/ruby-2.5.0'
generating transdb.h
transdb.h updated
compiling dln.c
compiling localeinit.c
creating verconf.h
verconf.h updated
compiling loadpath.c
compiling prelude.c
prelude.c: In function 'prelude_eval':
prelude.c:204: error: #pragma GCC diagnostic not allowed inside functions
prelude.c:205: error: #pragma GCC diagnostic not allowed inside functions
prelude.c:221: error: #pragma GCC diagnostic not allowed inside functions
At top level:
cc1: warning: unrecognized command line option "-Wno-self-assign"
cc1: warning: unrecognized command line option "-Wno-constant-logical-operand"
cc1: warning: unrecognized command line option "-Wno-parentheses-equality"
cc1: warning: unrecognized command line option "-Wno-tautological-compare"
make: *** [prelude.o] Error 1
kimura@www10268uf[2024]%

Attached patch fixes the issue.

ruby-2.5.0-template-prelude.c.tmpl.patch (729 Bytes) ruby-2.5.0-template-prelude.c.tmpl.patch Patch to fix the issue yasuhirokimura (Yasuhiro KIMURA), 12/26/2017 01:15 PM

Related issues

Is duplicate of Ruby trunk - Bug #14234: Failed to build on CentOS 6.9Closed

History

#1 Updated by hsbt (Hiroshi SHIBATA) 11 months ago

  • Is duplicate of Bug #14234: Failed to build on CentOS 6.9 added

#2 [ruby-dev:50402] Updated by hsbt (Hiroshi SHIBATA) 11 months ago

  • Status changed from Open to Rejected

It's duplicated with #14234

Also available in: Atom PDF